summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgmdev2023-10-11 12:41:21 -0400
committerjgmdev2023-10-11 12:41:21 -0400
commit909f89aa0b3beb730c0efa74637ef9f4ee4699d4 (patch)
tree7ca3ac04275c009a811cf45be865f9776e2d6fc0
downloadaur-909f89aa0b3beb730c0efa74637ef9f4ee4699d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5131bf21596b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = cairo-dock-wayland-git
+ pkgdesc = Light eye-candy fully themable animated dock with wayland support
+ pkgver = 3.4.99.r.bf8da4ef
+ pkgrel = 1
+ url = http://glx-dock.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = curl
+ depends = dbus-glib
+ depends = glu
+ depends = gtk3
+ depends = librsvg
+ depends = wayland
+ optdepends = wayfire-plugins-scale-ipc: Additional functionality on wayfire
+ provides = cairo-dock
+ conflicts = cairo-dock
+ source = cairo-dock::git+https://github.com/dkondor/cairo-dock-core.git#branch=wayland_new
+ sha256sums = SKIP
+
+pkgname = cairo-dock-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..873d71a5b646
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: jgmdev <jgmdev@gmail.com>
+# Contributor: FreeByrd <nelsonbyrd248@gmail.com>
+# Contributor: Tofe <chris.chapuis@gmail.com>
+# Contributor: erm67 <erm67@yahoo.it>
+
+pkgname=cairo-dock-wayland-git
+pkgver=3.4.99.r.bf8da4ef
+pkgrel=1
+pkgdesc='Light eye-candy fully themable animated dock with wayland support'
+arch=('i686' 'x86_64')
+url='http://glx-dock.org/'
+license=('GPL')
+depends=('curl' 'dbus-glib' 'glu' 'gtk3' 'librsvg' 'wayland')
+makedepends=('cmake' 'git')
+optdepends=(
+ 'wayfire-plugins-scale-ipc: Additional functionality on wayfire'
+)
+provides=('cairo-dock')
+conflicts=('cairo-dock')
+source=("cairo-dock::git+https://github.com/dkondor/cairo-dock-core.git#branch=wayland_new")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd cairo-dock
+
+ tag='3.4.99'
+ echo "${tag}.r$(git rev-list --count ${tag}..HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd cairo-dock
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd cairo-dock/build
+
+ make DESTDIR="${pkgdir}" install
+}