summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2018-11-29 20:21:31 +0100
committerValHue2018-11-29 20:21:31 +0100
commit2891d7babce176f52af48195b039d4661b499a17 (patch)
treebd486fa06a3b20e03f3a0ce8641f54d3b4ce7386
downloadaur-2891d7babce176f52af48195b039d4661b499a17.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..020711c72ee9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = caja-extensions
+ pkgdesc = Allows you to open files with administration privileges using the context menu when browsing your files with Caja.
+ pkgver = 1.20.1
+ pkgrel = 1
+ url = https://mate-desktop.org
+ arch = x86_64
+ groups = mate-extra
+ license = GPL
+ makedepends = intltool
+ makedepends = python
+ depends = caja
+ depends = caja-extensions-common
+ depends = gksu
+ source = https://pub.mate-desktop.org/releases/1.20/caja-extensions-1.20.1.tar.xz
+ sha256sums = 7610931d4a3135f2f3b88551652907e4ef25c48b3f18c8e83ecd65c3df606706
+
+pkgname = caja-gksu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51eb1683590e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+#
+# Contributor: ValHue <vhuelamo at gmail dot com>
+#
+pkgbase="caja-extensions"
+pkgname="caja-gksu"
+pkgver="1.20.1"
+pkgrel="1"
+pkgdesc="Allows you to open files with administration privileges using the \
+context menu when browsing your files with Caja."
+url="https://mate-desktop.org"
+arch=('x86_64')
+license=('GPL')
+groups=('mate-extra')
+depends=('caja' 'caja-extensions-common' 'gksu')
+makedepends=('intltool' 'python')
+source=("https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgbase-$pkgver.tar.xz")
+sha256sums=('7610931d4a3135f2f3b88551652907e4ef25c48b3f18c8e83ecd65c3df606706')
+
+build() {
+ cd ${pkgbase}-${pkgver}
+ PYTHON=/usr/bin/python2 ./configure \
+ --prefix=/usr \
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=656231
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd ${pkgbase}-${pkgver}
+ make -C gksu DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=4 sw=4 ft=sh et syn=sh ft=sh: