summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgxb1522020-04-16 19:40:15 +0800
committergxb1522020-04-16 19:40:15 +0800
commita98dd7224cbefe9f68627e27a5331ad01f95a969 (patch)
tree1a8255e5c5b49454ae3962b709ca10cdcec415b2
parent3f75586dd046e8a3b582f3567dd3a230144a1ea7 (diff)
downloadaur-a98dd7224cbefe9f68627e27a5331ad01f95a969.tar.gz
nothing
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb83cda28c9f..bbae4f16a552 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,14 @@ noextract=(${_pkgname})
options=("!strip")
provides=('cajviewer')
conflicts=('cajviewer')
-source=("http://viewer.d.cnki.net/CAJViewer-x86_64-libc-2.24.AppImage")
+source=("http://viewer.d.cnki.net/${_pkgname}")
sha256sums=("2ee4ca35cc031ebdc413bcb46d63bb1b7f720c7a9db45641e25614f589f4933f")
prepare() {
cd "${srcdir}"
chmod a+x ${_pkgname}
${srcdir}/${_pkgname} --appimage-extract
- sed -i "s+Exec=cajviewer+Exec=${_installdir}/${_pkgname} %U+" "squashfs-root/cajviewer.desktop"
+ sed -i "s+Exec=cajviewer+Exec=env DESKTOPINTEGRATION=no ${_installdir}/${_pkgname} %U+" "squashfs-root/cajviewer.desktop"
find "squashfs-root/usr/share/icons/hicolor" -type d -exec chmod 755 {} \;
}