summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:24:23 +0200
committerM0Rf302015-06-17 15:24:23 +0200
commit35fc2fd39bfecd9b816b5b25e99763f4811ac297 (patch)
tree4ad5191451f9266ca96ef871eca1ecee9da10452
downloadaur-35fc2fd39bfecd9b816b5b25e99763f4811ac297.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--cake.sh9
-rwxr-xr-xhttpd-cakephp.conf10
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d06a4365e79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cakephp
+ pkgdesc = The Rapid Development Framework for PHP
+ pkgver = 1.3.20
+ pkgrel = 1
+ url = http://cakephp.org/
+ arch = any
+ license = MIT
+ depends = php
+ source = cakephp-1.3.20.tar.gz::https://github.com/cakephp/cakephp/tarball/1.3.20
+ source = cake.sh
+ source = httpd-cakephp.conf
+ md5sums = 1ab70095945ddfe8cb2579141206ef72
+ md5sums = a3a711e2e32fe03976ed7737c22e0c56
+ md5sums = d206d584570dc1b740f0c9c252982f6c
+
+pkgname = cakephp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0db48686d026
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: M0Rf30
+pkgname=cakephp
+pkgver=1.3.20
+pkgrel=1
+pkgdesc='The Rapid Development Framework for PHP'
+arch=('any')
+url='http://cakephp.org/'
+license=('MIT')
+depends=('php')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/tarball/$pkgver"
+ 'cake.sh'
+ 'httpd-cakephp.conf')
+
+package() {
+ cd $srcdir/cakephp-cakephp-*
+ install -D -m 644 "cake/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ mkdir -p $pkgdir/usr/share/webapps
+ cp -R $srcdir/cakephp-cakephp-* "$pkgdir/usr/share/webapps/cakephp"
+ install -D -m 755 "$srcdir/cake.sh" "$pkgdir/usr/bin/cake"
+ install -D -m 755 "$srcdir/httpd-cakephp.conf" "$pkgdir/etc/webapps/cakephp/httpd-cakephp.conf"
+ mkdir -p $pkgdir/var/log/httpd/cakephp
+}
+
+md5sums=('1ab70095945ddfe8cb2579141206ef72'
+ 'a3a711e2e32fe03976ed7737c22e0c56'
+ 'd206d584570dc1b740f0c9c252982f6c')
diff --git a/cake.sh b/cake.sh
new file mode 100644
index 000000000000..9b7750c7dcaf
--- /dev/null
+++ b/cake.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+clear
+
+LIB="/usr/share/webapps/cakephp/cake/console/"
+APP=`pwd`
+
+exec php -q ${LIB}cake.php -working "${APP}" "$@"
+
+exit
diff --git a/httpd-cakephp.conf b/httpd-cakephp.conf
new file mode 100755
index 000000000000..9513ad24acda
--- /dev/null
+++ b/httpd-cakephp.conf
@@ -0,0 +1,10 @@
+Alias /cakephp "/usr/share/webapps/cakephp"
+ <Directory "/usr/share/webapps/cakephp">
+ AllowOverride All
+ Options FollowSymlinks
+ Order allow,deny
+ Allow from all
+ php_admin_value open_basedir "/srv/:/tmp/:/usr/share/webapps/:/etc/webapps:/usr/share/pear/"
+ </Directory>
+ ErrorLog "/var/log/httpd/cakephp/error.log"
+ CustomLog "/var/log/httpd/cakephp/access.log" combined