summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Wucher2015-07-09 11:09:05 +0200
committerThomas Wucher2015-07-09 11:21:55 +0200
commit6db1d184b3086a6baea01f85abe2920e12474440 (patch)
treebaeccc50b4e2d06c8565b8430346585fb8228888
downloadaur-6db1d184b3086a6baea01f85abe2920e12474440.tar.gz
Initial commit, calcelestial 1a7fe12
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--disable-geonames.patch19
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2430d314b9da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = calcelestial
+ pkgdesc = calculates positions, rise and set times of celestial bodies
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://www.steffenvogel.de/2012/12/23/cron-jobs-fur-sonnenauf-untergang/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ depends = libnova
+ source = https://github.com/stv0g/calcelestial/archive/0.3.tar.gz
+ source = disable-geonames.patch
+ md5sums = SKIP
+ md5sums = a4bc96095f1096c6357150577650c438
+
+pkgname = calcelestial
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cd23df69b9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=calcelestial
+pkgver=0.3
+pkgrel=1
+pkgdesc="calculates positions, rise and set times of celestial bodies"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="http://www.steffenvogel.de/2012/12/23/cron-jobs-fur-sonnenauf-untergang/"
+license=('GPL3')
+depends=('libnova')
+source=("https://github.com/stv0g/${pkgname}/archive/${pkgver}.tar.gz"
+ "disable-geonames.patch")
+md5sums=('SKIP'
+ 'a4bc96095f1096c6357150577650c438')
+conflicts=()
+provides=()
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -i ../disable-geonames.patch -p1
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-geonames
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/disable-geonames.patch b/disable-geonames.patch
new file mode 100644
index 000000000000..71e2cc5daf89
--- /dev/null
+++ b/disable-geonames.patch
@@ -0,0 +1,19 @@
+Index: calcelestial/src/calcelestial.c
+===================================================================
+--- calcelestial.orig/src/calcelestial.c
++++ calcelestial/src/calcelestial.c
+@@ -242,14 +242,6 @@ int main(int argc, char *argv[]) {
+ error = true;
+ }
+
+-#ifdef GEONAMES_SUPPORT
+- /* lookup place at http://geonames.org */
+- if (query && geonames_lookup(query, (struct pos *) &obs, NULL, 0) != 0) {
+- fprintf(stderr, "failed to lookup location: %s\n", query);
+- error = true;
+- }
+-#endif
+-
+ /* validate observer coordinates */
+ if (fabs(obs.lat) > 90) {
+ fprintf(stderr, "invalid latitude, use --lat\n");