summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Wucher2016-11-20 17:14:22 +0100
committerThomas Wucher2016-11-20 17:15:14 +0100
commita8bbdeb70eed52a438ea0b1d6e77e1a7a3164d93 (patch)
tree8d1966cf0a45494327f3872246bf34bfdec00895
parent6db1d184b3086a6baea01f85abe2920e12474440 (diff)
downloadaur-a8bbdeb70eed52a438ea0b1d6e77e1a7a3164d93.tar.gz
calcelestial 0.4.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--disable-geonames.patch19
3 files changed, 9 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2430d314b9da..cf0ed59aaab8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Nov 20 16:15:02 UTC 2016
pkgbase = calcelestial
pkgdesc = calculates positions, rise and set times of celestial bodies
- pkgver = 0.3
+ pkgver = 0.4.1
pkgrel = 1
url = http://www.steffenvogel.de/2012/12/23/cron-jobs-fur-sonnenauf-untergang/
arch = i686
@@ -9,10 +11,8 @@ pkgbase = calcelestial
arch = armv7h
license = GPL3
depends = libnova
- source = https://github.com/stv0g/calcelestial/archive/0.3.tar.gz
- source = disable-geonames.patch
- md5sums = SKIP
- md5sums = a4bc96095f1096c6357150577650c438
+ source = https://github.com/stv0g/calcelestial/archive/0.4.1.tar.gz
+ md5sums = cac61a6bfc245fba2df0d6a6e33d01e6
pkgname = calcelestial
diff --git a/PKGBUILD b/PKGBUILD
index 6cd23df69b9c..db6729324860 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
pkgname=calcelestial
-pkgver=0.3
+pkgver=0.4.1
pkgrel=1
pkgdesc="calculates positions, rise and set times of celestial bodies"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://www.steffenvogel.de/2012/12/23/cron-jobs-fur-sonnenauf-untergang/"
license=('GPL3')
depends=('libnova')
-source=("https://github.com/stv0g/${pkgname}/archive/${pkgver}.tar.gz"
- "disable-geonames.patch")
-md5sums=('SKIP'
- 'a4bc96095f1096c6357150577650c438')
+source=("https://github.com/stv0g/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('cac61a6bfc245fba2df0d6a6e33d01e6')
conflicts=()
provides=()
prepare() {
cd "${pkgname}-${pkgver}"
- patch -i ../disable-geonames.patch -p1
}
build() {
cd "${pkgname}-${pkgver}"
- ./autogen.sh
+ autoreconf -i
./configure --prefix=/usr --disable-geonames
make
}
diff --git a/disable-geonames.patch b/disable-geonames.patch
deleted file mode 100644
index 71e2cc5daf89..000000000000
--- a/disable-geonames.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: calcelestial/src/calcelestial.c
-===================================================================
---- calcelestial.orig/src/calcelestial.c
-+++ calcelestial/src/calcelestial.c
-@@ -242,14 +242,6 @@ int main(int argc, char *argv[]) {
- error = true;
- }
-
--#ifdef GEONAMES_SUPPORT
-- /* lookup place at http://geonames.org */
-- if (query && geonames_lookup(query, (struct pos *) &obs, NULL, 0) != 0) {
-- fprintf(stderr, "failed to lookup location: %s\n", query);
-- error = true;
-- }
--#endif
--
- /* validate observer coordinates */
- if (fabs(obs.lat) > 90) {
- fprintf(stderr, "invalid latitude, use --lat\n");