summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes Hilbert2023-08-02 14:34:50 +0200
committerHannes Hilbert2023-08-02 14:34:50 +0200
commitb43e70ff84345bb1f443f8b706f4f0740397a49a (patch)
tree47e500e4e847d6f084e5d047f7a9d111ae6bf4a6
downloadaur-b43e70ff84345bb1f443f8b706f4f0740397a49a.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD20
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faf3f16c5dc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = calendarsync-bin
+ pkgdesc = Stateless CLI tool to sync calendars across different calendaring systems
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/inovex/CalendarSync
+ arch = x86_64
+ license = MIT
+ provides = calendarsync
+ conflicts = calendarsync
+ options = !lto
+ source = calendarsync-0.6.2.tar.gz::https://github.com/inovex/CalendarSync/releases/download/v0.6.2/CalendarSync_0.6.2_linux_amd64.tar.gz
+ sha256sums = 750a82f593bb3073ed18d88f27fe7669e218b1d55a8813daea41cabc5d6c15e8
+
+pkgname = calendarsync-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..36220d618147
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.log
+*.pkg.tar
+.psci_modules
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cca19cb1bc0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Hannes Hilbert <calendarsync at hsht dot de>
+
+pkgname=calendarsync-bin
+pkgver=0.6.2
+pkgrel=1
+pkgdesc='Stateless CLI tool to sync calendars across different calendaring systems'
+arch=('x86_64')
+url='https://github.com/inovex/CalendarSync'
+license=('MIT')
+provides=('calendarsync')
+conflicts=('calendarsync')
+options=('!lto')
+source=("calendarsync-$pkgver.tar.gz::https://github.com/inovex/CalendarSync/releases/download/v$pkgver/CalendarSync_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('750a82f593bb3073ed18d88f27fe7669e218b1d55a8813daea41cabc5d6c15e8')
+
+package() {
+ cd "$srcdir/"
+ install -Dm755 CalendarSync "$pkgdir/usr/bin/calendarsync"
+ }
+