summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-08-14 16:28:56 +0200
committerChristopher Arndt2016-08-16 06:17:14 +0200
commit72949eb39fa4d659164876b5115c8977760335f3 (patch)
tree989a6988acd6de32b61cb52296061eeafd095331
parent3654a237ec21ebd4b954114dd9013cc9c4a89fec (diff)
downloadaur-72949eb39fa4d659164876b5115c8977760335f3.tar.gz
Package meta data update only
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--calf-fix-type-errors.patch69
3 files changed, 74 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f780cf47fcd..5c26b88ca730 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Dec 31 03:44:44 UTC 2015
+# Tue Aug 16 04:16:17 UTC 2016
pkgbase = calf-git
pkgdesc = LV2/JACK audio plug-ins for musicians (git version)
- pkgver = 0.0.60.r2353.6cbdc54
+ pkgver = 0.0.60.r2370.e7daf55
pkgrel = 1
- url = http://calf.sourceforge.net/
+ url = http://calf-studio-gear.org/
install = calf-git.install
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c32be4421bab..372336021bc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
_pkgname=calf
pkgname="${_pkgname}-git"
-pkgver=0.0.60.r2353.6cbdc54
+pkgver=0.0.60.r2370.e7daf55
pkgrel=1
pkgdesc="LV2/JACK audio plug-ins for musicians (git version)"
arch=('i686' 'x86_64')
-url="http://calf.sourceforge.net/"
+url="http://calf-studio-gear.org/"
license=('GPL' 'LGPL')
depends=('desktop-file-utils' 'fluidsynth' 'gtk-update-icon-cache' 'lash'
'lv2')
diff --git a/calf-fix-type-errors.patch b/calf-fix-type-errors.patch
new file mode 100644
index 000000000000..e08bbbbb4465
--- /dev/null
+++ b/calf-fix-type-errors.patch
@@ -0,0 +1,69 @@
+diff --git a/src/analyzer.cpp b/src/analyzer.cpp
+index fd42188..73f9d4e 100644
+--- a/src/analyzer.cpp
++++ b/src/analyzer.cpp
+@@ -471,12 +471,12 @@ void analyzer::draw(int subindex, float *data, int points, bool fftdone) const
+ //pumping up actual signal an erase surrounding
+ // sounds
+ fft_outL[_iter] = 0.25f * std::max(n * 0.6f * \
+- fabs(fft_outL[_iter]) - var1L , 1e-20);
++ fabs(fft_outL[_iter]) - var1L , 1e-20f);
+ if(_mode == 3 or _mode == 4) {
+ // do the same with R channel if needed
+ lastoutR = fft_outR[_iter];
+ fft_outR[_iter] = 0.25f * std::max(n * \
+- 0.6f * fabs(fft_outR[_iter]) - var1R , 1e-20);
++ 0.6f * fabs(fft_outR[_iter]) - var1R , 1e-20f);
+ }
+ break;
+ }
+diff --git a/src/jack_client.cpp b/src/jack_client.cpp
+index 886d51e..ceb4285 100644
+--- a/src/jack_client.cpp
++++ b/src/jack_client.cpp
+@@ -226,7 +226,7 @@ void jack_client::calculate_plugin_order(std::vector<int> &indices)
+ map<string, int>::const_iterator p = port_to_plugin.find((*k) + cnlen + 1);
+ if (p != port_to_plugin.end())
+ {
+- run_before.insert(make_pair<int, int>(p->second, i));
++ run_before.insert(pair<int, int>(p->second, i));
+ }
+ }
+ jack_free(conns);
+diff --git a/src/modules_dist.cpp b/src/modules_dist.cpp
+index 4b1b7f9..b0708bf 100644
+--- a/src/modules_dist.cpp
++++ b/src/modules_dist.cpp
+@@ -794,8 +794,8 @@ uint32_t tapesimulator_audio_module::process(uint32_t offset, uint32_t numsample
+ lfo2.advance(1);
+
+ // dot
+- rms = std::max((double)rms, (fabs(Lo) + fabs(Ro)) / 2);
+- input = std::max((double)input, (fabs(Lc) + fabs(Rc)) / 2);
++ rms = std::max((double)rms, (fabs(Lo) + fabs(Ro)) / 2.0);
++ input = std::max((double)input, (fabs(Lc) + fabs(Rc)) / 2.0);
+
+ float values[] = {inL, inR, outs[0][i], outs[1][i]};
+ meters.process(values);
+diff --git a/src/modules_limit.cpp b/src/modules_limit.cpp
+index 6b7dcb6..26195fa 100644
+--- a/src/modules_limit.cpp
++++ b/src/modules_limit.cpp
+@@ -429,7 +429,7 @@ uint32_t multibandlimiter_audio_module::process(uint32_t offset, uint32_t numsam
+ }
+
+ // write multiband coefficient to buffer
+- buffer[pos] = std::min(*params[param_limit] / std::max(fabs(tmpL), fabs(tmpR)), 1.0);
++ buffer[pos] = std::min(*params[param_limit] / std::max(fabs(tmpL), fabs(tmpR)), 1.0f);
+
+ // step forward in multiband buffer
+ pos = (pos + channels) % buffer_size;
+@@ -811,7 +811,7 @@ uint32_t sidechainlimiter_audio_module::process(uint32_t offset, uint32_t numsam
+ }
+
+ // write multiband coefficient to buffer
+- buffer[pos] = std::min(*params[param_limit] / std::max(fabs(tmpL), fabs(tmpR)), 1.0);
++ buffer[pos] = std::min(*params[param_limit] / std::max(fabs(tmpL), fabs(tmpR)), 1.0f);
+
+ // step forward in multiband buffer
+ pos = (pos + channels) % buffer_size;