summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeteros2017-04-03 08:54:57 +0000
committerTeteros2017-04-03 08:54:57 +0000
commit2349298498fdfeaa523d029f830dd8479dbf3dc2 (patch)
tree8b8f63c1efb48881ea6aa9a76c6f0b4c99f44a56
downloadaur-2349298498fdfeaa523d029f830dd8479dbf3dc2.tar.gz
init repo
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
-rw-r--r--calf-0.0.19kx-gcc6.patch45
3 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73d7eb74f139
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = calf-ladspa
+ pkgdesc = JACK audio plug-ins for musicians (Legacy LADSPA+RDF version)
+ pkgver = 0.0.19kx
+ pkgrel = 1
+ url = http://calf-studio-gear.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = ladspa
+ depends = fftw
+ depends = fluidsynth
+ source = http://urchlay.naptime.net/~urchlay/src/calf-0.0.19kx.tar.gz
+ source = calf-0.0.19kx-gcc6.patch
+ md5sums = ba2147ddc53022ddf1ffdf28c3340a57
+ md5sums = 66155856ccc4e0358d3bdf703ec0e414
+
+pkgname = calf-ladspa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac3757c32130
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Teteros <teteros -at- openmailbox -dot- org>
+
+_pkgname=calf
+pkgname=calf-ladspa
+pkgver=0.0.19kx
+pkgrel=1
+pkgdesc="JACK audio plug-ins for musicians (Legacy LADSPA+RDF version)"
+arch=(i686 x86_64)
+url="http://calf-studio-gear.org/"
+license=(LGPL)
+depends=(fftw fluidsynth)
+makedepends=(ladspa)
+source=("http://urchlay.naptime.net/~urchlay/src/$_pkgname-$pkgver.tar.gz" "$_pkgname-$pkgver-gcc6.patch")
+md5sums=('ba2147ddc53022ddf1ffdf28c3340a57' '66155856ccc4e0358d3bdf703ec0e414')
+
+prepare(){
+ cd "$_pkgname-$pkgver"
+ patch -p1 < "${srcdir}/$_pkgname-$pkgver-gcc6.patch"
+}
+
+build() {
+ cd "${srcdir}/$_pkgname-$pkgver"
+ autoreconf -if
+ ./configure \
+ --prefix=/usr \
+ --with-ladspa-dir=/usr/lib/ladspa \
+ --disable-experimental \
+ --enable-sse \
+ --without-dssi \
+ --without-lash \
+ --without-lv2
+ make
+}
+
+package() {
+ cd "${srcdir}/$_pkgname-$pkgver/src"
+ msg2 "Copying LADSPA files for install..."
+ mkdir -p "${pkgdir}/usr/lib/ladspa" "${pkgdir}/usr/share/ladspa/rdf"
+ install .libs/calf.so "${pkgdir}/usr/lib/ladspa"
+ msg2 "Generating RDF metadata..."
+ ./calfmakerdf > "${pkgdir}/usr/share/ladspa/rdf/calf.rdf"
+}
+
+# vim:set ts=4 sw=4 et:
diff --git a/calf-0.0.19kx-gcc6.patch b/calf-0.0.19kx-gcc6.patch
new file mode 100644
index 000000000000..3dc39cbcfd0a
--- /dev/null
+++ b/calf-0.0.19kx-gcc6.patch
@@ -0,0 +1,45 @@
+diff -aur calf-0.0.19kx.pristine/src/jack_client.cpp calf-0.0.19kx.new/src/jack_client.cpp
+--- calf-0.0.19kx.pristine/src/jack_client.cpp 2014-03-08 21:26:41.000000000 +0000
++++ calf-0.0.19kx.new/src/jack_client.cpp 2017-04-03 07:17:35.538093145 +0000
+@@ -163,7 +163,7 @@
+ map<string, int>::const_iterator p = port_to_plugin.find((*k) + cnlen + 1);
+ if (p != port_to_plugin.end())
+ {
+- run_before.insert(make_pair<int, int>(p->second, i));
++ run_before.insert(make_pair<int, int>(static_cast<int>(p->second), i));
+ }
+ }
+ jack_free(conns);
+diff -aur calf-0.0.19kx.pristine/src/modules.cpp calf-0.0.19kx.new/src/modules.cpp
+--- calf-0.0.19kx.pristine/src/modules.cpp 2014-03-08 21:26:41.000000000 +0000
++++ calf-0.0.19kx.new/src/modules.cpp 2017-04-03 07:39:33.828088388 +0000
+@@ -1427,13 +1427,13 @@
+ //pumping up actual signal an erase surrounding
+ // sounds
+ fft_outL[_iter] = 0.25f * std::max(n * 0.6f * \
+- fabs(fft_outL[_iter]) - var1L , 1e-20);
+- if(_param_mode == 3 or _param_mode == 4) {
++ fabs(fft_outL[_iter]) - var1L , 1e-20f);
++ if(_param_mode == 3 or _param_mode == 4) {
+ // do the same with R channel if needed
+ lastoutR = fft_outR[_iter];
+ fft_outR[_iter] = 0.25f * std::max(n * \
+- 0.6f * fabs(fft_outR[_iter]) - var1R , 1e-20);
+- }
++ 0.6f * fabs(fft_outR[_iter]) - var1R , 1e-20f);
++ }
+ break;
+ }
+ break;
+diff -aur calf-0.0.19kx.pristine/src/modules_limit.cpp calf-0.0.19kx.new/src/modules_limit.cpp
+--- calf-0.0.19kx.pristine/src/modules_limit.cpp 2014-03-08 21:26:41.000000000 +0000
++++ calf-0.0.19kx.new/src/modules_limit.cpp 2017-04-03 07:21:13.618092358 +0000
+@@ -544,7 +544,7 @@
+ } // process single strip with filter
+
+ // write multiband coefficient to buffer
+- buffer[pos] = std::min(*params[param_limit] / std::max(fabs(sum_left), fabs(sum_right)), 1.0);
++ buffer[pos] = *params[param_limit] / std::max(fabs(sum_left), fabs(sum_right)) < 1.0 ? *params[param_limit] / std::max(fabs(sum_left), fabs(sum_right)) : 1.0;
+
+ for (int i = 0; i < strips; i++) {
+ // process gain reduction