summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeteros2020-04-22 00:50:56 +0100
committerTeteros2020-04-22 00:50:56 +0100
commitc5d17f5cff5ddb5c4b73e7c992983f3ec468d7cc (patch)
treea53c77546b77087d47d7d08c9c6a89d41ea0e8d2
parent47202481ee1f0d25474f52ffce0e040953f28713 (diff)
downloadaur-c5d17f5cff5ddb5c4b73e7c992983f3ec468d7cc.tar.gz
Make package more reproducible
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD43
2 files changed, 34 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ae09c985dec..54ca6ac31a35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = calf-ladspa
- pkgdesc = JACK audio plug-ins for musicians (LADSPA lmms fork)
- pkgver = 0.90
- pkgrel = 2
+ pkgdesc = JACK audio plug-ins for musicians (LADSPA version)
+ pkgver = 0.90.1.0
+ pkgrel = 1
url = https://github.com/LMMS/veal
arch = i686
arch = x86_64
groups = ladspa-plugins
- license = LGPL
- makedepends = ladspa
+ groups = pro-audio
+ license = LGPL2.1
makedepends = cmake
+ depends = ladspa
conflicts = lmms
- noextract = ladspa.zip
- source = https://github.com/LMMS/veal/archive/ladspa.zip
- source = https://raw.githubusercontent.com/LMMS/lmms/master/plugins/LadspaEffect/calf/CMakeLists.txt
- source = https://raw.githubusercontent.com/LMMS/lmms/master/plugins/LadspaEffect/calf/config.h.in
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ noextract = f889b76ff8d288df6f2ea4c9e315632b63831039.tar.gz
+ source = https://github.com/LMMS/veal/archive/f889b76ff8d288df6f2ea4c9e315632b63831039.tar.gz
+ source = https://raw.githubusercontent.com/LMMS/lmms/aa0ce7fc545bbf2f63cb4df8853c1de474faba0d/plugins/LadspaEffect/calf/CMakeLists.txt
+ source = https://raw.githubusercontent.com/LMMS/lmms/ae0dd21df30fb42a2194e2752d1c00ea0d2afdb9/plugins/LadspaEffect/calf/config.h.in
+ sha256sums = 38280b04d18a58ef105c6cc1570f544c3c9d22cbf9a7d692a8725268bccb48f3
+ sha256sums = e9f94704e2cfbdca02e729aebcf5da9e65a9ebbead5434b69a29872a9ffdb63c
+ sha256sums = 8cd19eb7f19ecdbcbe3b82f91e703981f0c36d348d6a150f640ab2162d8cbad4
pkgname = calf-ladspa
diff --git a/PKGBUILD b/PKGBUILD
index c9eaf79c19e6..60b257fc408a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,35 @@
# Maintainer: Teteros <teteros at teknik dot io>
_forkname=veal
+_commit=f889b76ff8d288df6f2ea4c9e315632b63831039
pkgname=calf-ladspa
-pkgver=0.90
-pkgrel=2
-pkgdesc="JACK audio plug-ins for musicians (LADSPA lmms fork)"
-arch=('i686' 'x86_64')
+pkgver=0.90.1.0
+pkgrel=1
+pkgdesc="JACK audio plug-ins for musicians (LADSPA version)"
+arch=(i686 x86_64)
url="https://github.com/LMMS/veal"
-license=('LGPL')
-groups=('ladspa-plugins')
-makedepends=('ladspa' 'cmake')
-conflicts=('lmms')
-source=("https://github.com/LMMS/$_forkname/archive/ladspa.zip"
- "https://raw.githubusercontent.com/LMMS/lmms/master/plugins/LadspaEffect/calf/CMakeLists.txt"
- "https://raw.githubusercontent.com/LMMS/lmms/master/plugins/LadspaEffect/calf/config.h.in")
-noextract=('ladspa.zip')
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+license=(LGPL2.1)
+groups=(ladspa-plugins pro-audio)
+depends=(ladspa)
+makedepends=(cmake)
+conflicts=(lmms)
+source=("https://github.com/LMMS/$_forkname/archive/$_commit.tar.gz"
+ "https://raw.githubusercontent.com/LMMS/lmms/aa0ce7fc545bbf2f63cb4df8853c1de474faba0d/plugins/LadspaEffect/calf/CMakeLists.txt"
+ "https://raw.githubusercontent.com/LMMS/lmms/ae0dd21df30fb42a2194e2752d1c00ea0d2afdb9/plugins/LadspaEffect/calf/config.h.in")
+noextract=("$_commit.tar.gz")
+sha256sums=('38280b04d18a58ef105c6cc1570f544c3c9d22cbf9a7d692a8725268bccb48f3'
+ 'e9f94704e2cfbdca02e729aebcf5da9e65a9ebbead5434b69a29872a9ffdb63c'
+ '8cd19eb7f19ecdbcbe3b82f91e703981f0c36d348d6a150f640ab2162d8cbad4')
prepare(){
- mkdir -p "$_forkname/build"
- bsdtar -xf ladspa.zip --strip-components=1 -C "$_forkname"
+ mkdir "$_forkname"
+ bsdtar -xf "$_commit.tar.gz" --strip-components=1 -C "$_forkname"
}
build() {
- cd "$srcdir/$_forkname/build"
- cmake -Wno-dev "$srcdir"
- make
+ cmake -S "$_forkname" -B build -Wno-dev -DCMAKE_BUILD_TYPE=Release --build .
}
package() {
- cd "$srcdir/$_forkname/build"
- make DESTDIR="$pkgdir/usr/lib" install
+ make DESTDIR="$pkgdir/usr/lib" -C build install
}
-
-# vim:set sw=2 ts=2 indentexpr=GetShIndent() et: