summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Pöhlmann2018-08-31 08:19:25 +0200
committerMartin Pöhlmann2018-08-31 08:19:25 +0200
commit09f1d4d3d44545dbb3d9c4c1fb442e42cd1eb963 (patch)
treef8639179d4bd3ca004415c9d22bd7b92efcb2403
parent74824f26a6df417b87c0ce4711bab4c213916b09 (diff)
downloadaur-09f1d4d3d44545dbb3d9c4c1fb442e42cd1eb963.tar.gz
Apply latest patches and disable strict warning checking
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 781a4938b10b..c25dd221a0da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by makepkg 4.2.1
-# Fri Apr 17 05:48:33 UTC 2015
pkgbase = california
pkgdesc = A new calendar application for GNOME 3. It is currently under heavy development.
pkgver = 0.4.0
@@ -19,9 +17,11 @@ pkgbase = california
depends = libgee
depends = xdg-utils
source = https://download.gnome.org/sources/california/0.4/california-0.4.0.tar.xz
- source = http://pkgs.fedoraproject.org/cgit/california.git/plain/0002-Build-with-evolution-data-server-3.13.90.patch
+ source = https://src.fedoraproject.org/cgit/rpms/california.git/plain/0002-Build-with-evolution-data-server-3.13.90.patch
+ source = https://src.fedoraproject.org/cgit/rpms/california.git/plain/california-0.4.0-libical-3.0.patch
sha256sums = b25f356363a9f8f8f93c7ab78af02de39f9c3b71964663129ac9904de9147eb6
sha256sums = f512f50470954ec4018c99c49c37fa7e23074653a2e090ff13e32631ec10293d
+ sha256sums = c6924c868d2b44639463ce7e426c5917377ec7d0d6aa0fd38f7a018a9563be33
pkgname = california
diff --git a/PKGBUILD b/PKGBUILD
index e1d27ab47e63..ea6a717f9dba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,24 @@ license=('LGPL2.1')
depends=('evolution-data-server' 'libgee' 'xdg-utils')
makedepends=('vala' 'intltool' 'gnome-common' 'yelp-tools' 'gobject-introspection' 'patch')
install="${pkgname}.install"
-source=('https://download.gnome.org/sources/california/0.4/california-0.4.0.tar.xz' 'http://pkgs.fedoraproject.org/cgit/california.git/plain/0002-Build-with-evolution-data-server-3.13.90.patch')
-sha256sums=('b25f356363a9f8f8f93c7ab78af02de39f9c3b71964663129ac9904de9147eb6' 'f512f50470954ec4018c99c49c37fa7e23074653a2e090ff13e32631ec10293d')
+source=(
+ 'https://download.gnome.org/sources/california/0.4/california-0.4.0.tar.xz'
+ 'https://src.fedoraproject.org/cgit/rpms/california.git/plain/0002-Build-with-evolution-data-server-3.13.90.patch'
+ 'https://src.fedoraproject.org/cgit/rpms/california.git/plain/california-0.4.0-libical-3.0.patch'
+)
+sha256sums=(
+ 'b25f356363a9f8f8f93c7ab78af02de39f9c3b71964663129ac9904de9147eb6'
+ 'f512f50470954ec4018c99c49c37fa7e23074653a2e090ff13e32631ec10293d'
+ 'c6924c868d2b44639463ce7e426c5917377ec7d0d6aa0fd38f7a018a9563be33'
+)
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 < ../0002-Build-with-evolution-data-server-3.13.90.patch
+ patch -p1 < ../california-0.4.0-libical-3.0.patch
./configure \
- --prefix=/usr
+ --prefix=/usr \
+ --disable-fatal
sed -i 's#californiadocdir = ${prefix}#californiadocdir = ${datadir}#g' Makefile
make
}