summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-01-06 00:18:23 +0100
committerPhilip Goto2021-01-06 00:18:23 +0100
commit5310ef8be5e04382841f926c0b177f8ca2d686ef (patch)
tree80fcba1b39484b49b1993b662e23474a5b081579
parenta7e60db8a78a4cc6cca0c5f1b895cbe62458b949 (diff)
downloadaur-5310ef8be5e04382841f926c0b177f8ca2d686ef.tar.gz
Remove prepare (issue fixed)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 760773924bbf..85fc0428ce12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = callaudiod-git
pkgdesc = Call audio routing daemon
- pkgver = 0.0.4.r2.g6c8ffc2
+ pkgver = 0.0.4.r4.g585f3da
pkgrel = 1
url = https://gitlab.com/mobian1/callaudiod
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index f41ade17b489..61b5853f71e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=callaudiod-git
-pkgver=0.0.4.r2.g6c8ffc2
+pkgver=0.0.4.r4.g585f3da
pkgrel=1
pkgdesc="Call audio routing daemon"
arch=(i686 x86_64 armv7h aarch64)
@@ -14,24 +14,20 @@ conflicts=(callaudiod)
source=("git+${url}.git")
md5sums=(SKIP)
-prepare() {
- ln -s ../src/callaudiod.h callaudiod/libcallaudio/callaudiod.h
-}
-
pkgver() {
- cd callaudiod
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd callaudiod
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson callaudiod build
- meson compile -C build
+ arch-meson callaudiod build
+ meson compile -C build
}
check() {
- meson test -C build --print-errorlogs
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ DESTDIR="${pkgdir}" meson install -C build
}