summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Baxter2024-01-18 09:29:04 +1300
committerJeremy Baxter2024-01-18 09:29:04 +1300
commit455eaf773cddc6bd79400eca52d77e64598abd9e (patch)
tree7c944c45dac4cc4a7a865ee8d9cfd12f0af9337f
downloadaur-455eaf773cddc6bd79400eca52d77e64598abd9e.tar.gz
create initial pkgbuild and srcinfo
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7d21b2037d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = callisto-git
+ pkgdesc = standalone scripting platform for Lua 5.4
+ pkgver = v0.1.0.r97.g019fea4
+ pkgrel = 1
+ url = https://github.com/jtbx/callisto
+ arch = x86_64
+ license = GPL
+ options = !emptydirs
+ source = callisto-git::git+https://github.com/jtbx/callisto.git
+ sha256sums = SKIP
+
+pkgname = callisto-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c552b8b2284f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jeremy Baxter <jtbx@disroot.org>
+
+pkgname=callisto-git
+pkgver=v0.1.0.r97.g019fea4
+pkgrel=1
+pkgdesc='standalone scripting platform for Lua 5.4'
+arch=('x86_64')
+url='https://github.com/jtbx/callisto'
+license=('GPL')
+options=('!emptydirs')
+source=("$pkgname::git+https://github.com/jtbx/callisto.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ make -j$(nproc)
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}