summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-10-22 14:26:33 +0200
committerCarl Smedstad2023-10-22 14:38:52 +0200
commit9cb94890d74dc400cce05d27e38c0bcbe3830f67 (patch)
tree9977c031d68c35c620833cdd503f1e63babdcbb5
parente09d991e6665c026e1018fbd4fabf9c6e794844a (diff)
downloadaur-9cb94890d74dc400cce05d27e38c0bcbe3830f67.tar.gz
Publish version 45.0-1
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD92
-rw-r--r--remove-failing-tests.patch53
4 files changed, 141 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b41d4807f52..4cb3b22bc941 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,41 @@
pkgbase = calls
pkgdesc = Phone dialer and call handler
- pkgver = 43.0
+ pkgver = 45.0
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/calls
arch = x86_64
arch = aarch64
license = GPL3
- makedepends = git
- makedepends = gobject-introspection
+ checkdepends = gst-plugins-bad
+ checkdepends = gst-plugins-base
+ checkdepends = gst-plugins-good
+ checkdepends = gst-plugins-ugly
makedepends = meson
+ makedepends = python-docutils
makedepends = vala
depends = callaudiod
+ depends = dconf
depends = evolution-data-server
depends = feedbackd
depends = folks
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
depends = gom
+ depends = gstreamer
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libgee
depends = libhandy
+ depends = libmm-glib
depends = libpeas
- depends = modemmanager
+ depends = libsecret
depends = sofia-sip
- source = git+https://gitlab.gnome.org/GNOME/calls.git#tag=v43.0
- source = git+https://gitlab.gnome.org/World/Phosh/libcall-ui.git
- b2sums = SKIP
- b2sums = SKIP
+ source = calls-45.0.tar.gz::https://gitlab.gnome.org/GNOME/calls/-/archive/v45.0/calls-v45.0.tar.gz
+ source = libcall-ui-0.1.0::https://gitlab.gnome.org/World/Phosh/libcall-ui/-/archive/v0.1.0/libcall-ui-v0.1.0.tar.gz
+ source = remove-failing-tests.patch
+ sha256sums = 60822ecd41a997c93966765648d7d3412a7350613da1310cccee6e27ab3c1035
+ sha256sums = a3dec58c622fb418c69085c4a20c2804058864d8b74f4af751e9c96b3ecafede
+ sha256sums = d4411f7eed3ac49ce78eb04e139ecc213ed02559ed8a8fb2337dca06969aab86
pkgname = calls
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c8b56c2430a0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!remove-failing-tests.patch
diff --git a/PKGBUILD b/PKGBUILD
index 5f71c3c0b82d..0a9b6b8384ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,84 @@
-# Maintainer: Yassine Oudjana <y.oudjana@protonmail.com>
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: Yassine Oudjana <y.oudjana@protonmail.com>
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=calls
-pkgver=43.0
+pkgver=45.0
pkgrel=1
-pkgdesc='Phone dialer and call handler'
+pkgdesc="Phone dialer and call handler"
arch=(x86_64 aarch64)
-url='https://gitlab.gnome.org/GNOME/calls'
+url="https://gitlab.gnome.org/GNOME/calls"
license=(GPL3)
depends=(
- callaudiod
- evolution-data-server
- feedbackd
- folks
- gom
- libhandy
- libpeas
- modemmanager
- sofia-sip
+ callaudiod
+ dconf
+ evolution-data-server
+ feedbackd
+ folks
+ gcc-libs
+ glib2
+ glibc
+ gom
+ gstreamer
+ gtk3
+ hicolor-icon-theme
+ libgee
+ libhandy
+ libmm-glib
+ libpeas
+ libsecret
+ sofia-sip
)
makedepends=(
- git
- gobject-introspection
- meson
- vala
+ meson
+ python-docutils
+ vala
)
+checkdepends=(
+ gst-plugins-bad
+ gst-plugins-base
+ gst-plugins-good
+ gst-plugins-ugly
+)
+
+_libcall_version=0.1.0
+
source=(
- "git+${url}.git#tag=v${pkgver}"
- "git+https://gitlab.gnome.org/World/Phosh/libcall-ui.git"
+ "$pkgname-$pkgver.tar.gz::$url/-/archive/v$pkgver/calls-v$pkgver.tar.gz"
+ "libcall-ui-$_libcall_version::https://gitlab.gnome.org/World/Phosh/libcall-ui/-/archive/v$_libcall_version/libcall-ui-v$_libcall_version.tar.gz"
+ "remove-failing-tests.patch"
)
-b2sums=('SKIP'
- 'SKIP')
+sha256sums=(
+ '60822ecd41a997c93966765648d7d3412a7350613da1310cccee6e27ab3c1035'
+ 'a3dec58c622fb418c69085c4a20c2804058864d8b74f4af751e9c96b3ecafede'
+ 'd4411f7eed3ac49ce78eb04e139ecc213ed02559ed8a8fb2337dca06969aab86'
+)
+
+_archive="$pkgname-v$pkgver"
prepare() {
- cd $pkgname
+ rm -r "$_archive/subprojects/libcall-ui"
+ cp -r libcall-ui-v$_libcall_version "$_archive/subprojects/libcall-ui"
- git submodule init
- git submodule set-url subprojects/libcall-ui "../libcall-ui"
- git -c protocol.file.allow=always submodule update
+ cd "$_archive"
+ patch -Np1 -i "$srcdir/remove-failing-tests.patch"
}
-
build() {
- cd $pkgname
- arch-meson . _build
- ninja -C _build
+ cd "$_archive"
+
+ arch-meson . build
+ meson compile -C build
+}
+
+check() {
+ cd "$_archive"
+
+ meson test -C build --print-errorlogs
}
package() {
- cd $pkgname
+ cd "$_archive"
- DESTDIR="${pkgdir}" ninja install -C _build
+ meson install -C build --destdir "$pkgdir"
}
diff --git a/remove-failing-tests.patch b/remove-failing-tests.patch
new file mode 100644
index 000000000000..317230e143c4
--- /dev/null
+++ b/remove-failing-tests.patch
@@ -0,0 +1,53 @@
+diff --unified --recursive --text calls-v45.0.orig/plugins/provider/tests/meson.build calls-v45.0/plugins/provider/tests/meson.build
+--- calls-v45.0.orig/plugins/provider/tests/meson.build 2023-10-21 19:55:07.143448431 +0200
++++ calls-v45.0/plugins/provider/tests/meson.build 2023-10-21 20:02:01.958469795 +0200
+@@ -96,21 +96,6 @@
+ )
+ test('media', t, env: test_env)
+
+-test_sources = [ 'test-sip.c' ]
+-test_sources += sip_sources
+-t = executable('sip', test_sources,
+- c_args : test_cflags,
+- link_args: test_link_args,
+- pie: true,
+- link_with : [calls_vala, libcalls],
+- dependencies: [calls_deps, sip_deps],
+- include_directories : [
+- calls_includes,
+- sip_include,
+- ]
+- )
+-test('sip', t, env: test_env)
+-
+ test_sources = [ 'test-srtp.c' ]
+ test_sources += sip_sources
+ t = executable('srtp', test_sources,
+diff --unified --recursive --text calls-v45.0.orig/tests/meson.build calls-v45.0/tests/meson.build
+--- calls-v45.0.orig/tests/meson.build 2023-10-21 19:55:07.153448468 +0200
++++ calls-v45.0/tests/meson.build 2023-10-21 20:00:36.888101563 +0200
+@@ -165,24 +165,4 @@
+
+ dbus_run_session = find_program('dbus-run-session')
+
+-if dbus_run_session.found ()
+- test_sources = [ 'test-application.c' ]
+- t = executable('application', test_sources, calls_resources,
+- c_args : test_cflags,
+- link_args: test_link_args,
+- pie: true,
+- link_with : [calls_vala, libcalls],
+- dependencies: calls_deps,
+- include_directories : [
+- calls_includes,
+- ]
+- )
+- test('application',
+- dbus_run_session,
+- args: t.full_path(),
+- env: test_env,
+- timeout : 300
+- )
+-endif
+-
+ endif