summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYassine Oudjana2022-11-16 18:42:16 +0400
committerYassine Oudjana2022-11-16 18:42:16 +0400
commite09d991e6665c026e1018fbd4fabf9c6e794844a (patch)
tree708046a91f1ee6e3e740d0de03976c2b613fa8e6
parenta2fd23de4a3d8a4da44f2d5d1ed9c8143edebe14 (diff)
downloadaur-e09d991e6665c026e1018fbd4fabf9c6e794844a.tar.gz
Update to 43.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3912751aee5..6b41d4807f52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = calls
pkgdesc = Phone dialer and call handler
- pkgver = 42.0
+ pkgver = 43.0
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/calls
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = calls
makedepends = meson
makedepends = vala
depends = callaudiod
+ depends = evolution-data-server
depends = feedbackd
depends = folks
depends = gom
@@ -18,8 +19,7 @@ pkgbase = calls
depends = libpeas
depends = modemmanager
depends = sofia-sip
- options = debug
- source = git+https://gitlab.gnome.org/GNOME/calls.git#commit=42.0
+ source = git+https://gitlab.gnome.org/GNOME/calls.git#tag=v43.0
source = git+https://gitlab.gnome.org/World/Phosh/libcall-ui.git
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6a9e2262ddd9..5f71c3c0b82d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Yassine Oudjana <y.oudjana@protonmail.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=calls
-pkgver=42.0
+pkgver=43.0
pkgrel=1
pkgdesc='Phone dialer and call handler'
arch=(x86_64 aarch64)
@@ -9,6 +10,7 @@ url='https://gitlab.gnome.org/GNOME/calls'
license=(GPL3)
depends=(
callaudiod
+ evolution-data-server
feedbackd
folks
gom
@@ -23,32 +25,30 @@ makedepends=(
meson
vala
)
-options=(debug)
-_commit=${pkgver}
source=(
- "git+${url}.git#commit=$_commit"
+ "git+${url}.git#tag=v${pkgver}"
"git+https://gitlab.gnome.org/World/Phosh/libcall-ui.git"
)
-b2sums=('SKIP' 'SKIP')
+b2sums=('SKIP'
+ 'SKIP')
prepare() {
- cd calls
+ cd $pkgname
git submodule init
- git submodule set-url subprojects/libcall-ui "$srcdir/libcall-ui"
- git submodule update
+ git submodule set-url subprojects/libcall-ui "../libcall-ui"
+ git -c protocol.file.allow=always submodule update
}
build() {
- arch-meson calls build -D tests=false
- meson compile -C build
-}
-
-check() {
- meson test -C build --print-errorlogs
+ cd $pkgname
+ arch-meson . _build
+ ninja -C _build
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ cd $pkgname
+
+ DESTDIR="${pkgdir}" ninja install -C _build
}