summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-09 12:54:41 +0800
committerzxp198210052023-11-09 12:54:41 +0800
commit528cd96a8ba58f4b4b6ff4d4cf7b1855892b51b3 (patch)
tree3ff185503686aa43a568e47994133d85679760fc
parent8b9722fe5e4c81e86d605012f88b887ffdf0065b (diff)
downloadaur-528cd96a8ba58f4b4b6ff4d4cf7b1855892b51b3.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD33
-rw-r--r--calmly-writer.sh7
3 files changed, 31 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa36b51fb783..12188ee72660 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = calmly-writer-bin
- pkgdesc = Calmly Writer is an editor designed to focus on what you want to tell, with a simple, unobtrusive and ease-to-use user interface.
+ pkgdesc = An editor designed to focus on what you want to tell, with a simple, unobtrusive and ease-to-use user interface.
pkgver = 2.0.54
- pkgrel = 3
+ pkgrel = 4
url = https://www.calmlywriter.com
arch = aarch64
arch = x86_64
license = custom
makedepends = asar
- depends = bash
depends = electron24
depends = hicolor-icon-theme
+ depends = lib32-glibc
+ depends = lib32-gcc-libs
provides = calmly-writer=2.0.54
conflicts = calmly-writer
source = LICENSE.html::https://www.calmlywriter.com/eula.htm
source = calmly-writer.sh
sha256sums = 79f277c107ca3402d156db2ced6ea619a966216097c8d4d17692bada193b3edb
- sha256sums = df7583360a6f6607332c59670fc00f758f6bfc5ec2167b36e556f67e6446bd10
+ sha256sums = a8f5c4df1de2242cc3b18d89b2b8db8fd78ed6d505db7fd2a715e55c28001e7c
source_aarch64 = calmly-writer_2.0.54-aarch64.deb::https://www.calmlywriter.com/releases/linux/deb/arm64/calmly-writer_2.0.54_arm64.deb
sha256sums_aarch64 = dd7606298580fbf26c3882cdf83286db563680c9ef757cdceba6a605d8bbf11e
source_x86_64 = calmly-writer_2.0.54-x86_64.deb::https://www.calmlywriter.com/releases/linux/deb/x64/calmly-writer_2.0.54_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 6b890c91b95b..3c50458f526c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,42 @@
pkgname=calmly-writer-bin
_pkgname="Calmly Writer"
pkgver=2.0.54
-pkgrel=3
-pkgdesc="Calmly Writer is an editor designed to focus on what you want to tell, with a simple, unobtrusive and ease-to-use user interface."
-arch=('aarch64' 'x86_64')
+pkgrel=4
+pkgdesc="An editor designed to focus on what you want to tell, with a simple, unobtrusive and ease-to-use user interface."
+arch=(
+ 'aarch64'
+ 'x86_64'
+)
url="https://www.calmlywriter.com"
license=('custom')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
-depends=('bash' 'electron24' 'hicolor-icon-theme')
+depends=(
+ 'electron24'
+ 'hicolor-icon-theme'
+ 'lib32-glibc'
+ 'lib32-gcc-libs'
+)
makedepends=('asar')
source_aarch64=("${pkgname%-bin}_${pkgver}-aarch64.deb::${url}/releases/linux/deb/arm64/${pkgname%-bin}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}_${pkgver}-x86_64.deb::${url}/releases/linux/deb/x64/${pkgname%-bin}_${pkgver}_amd64.deb")
-source=("LICENSE.html::${url}/eula.htm"
- "${pkgname%-bin}.sh")
+source=(
+ "LICENSE.html::${url}/eula.htm"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('79f277c107ca3402d156db2ced6ea619a966216097c8d4d17692bada193b3edb'
- 'df7583360a6f6607332c59670fc00f758f6bfc5ec2167b36e556f67e6446bd10')
+ 'a8f5c4df1de2242cc3b18d89b2b8db8fd78ed6d505db7fd2a715e55c28001e7c')
sha256sums_aarch64=('dd7606298580fbf26c3882cdf83286db563680c9ef757cdceba6a605d8bbf11e')
sha256sums_x86_64=('91432bec316b83ef3a0e47815c4db9ec38903704e19c61e29f32782f327a3897')
-prepare() {
+build() {
bsdtar -xf "${srcdir}/data.tar.xz"
- asar e "${srcdir}/opt/${_pkgname}/resources/app.asar" "${srcdir}/app.asar.unpacked"
- cp -r "${srcdir}/opt/${_pkgname}/resources/app.asar.unpacked" "${srcdir}"
- asar p "${srcdir}/app.asar.unpacked" "${srcdir}/${pkgname%-bin}.asar"
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\" %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${pkgname%-bin}.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ cp -r "${srcdir}/opt/${_pkgname}/resources/app.asar.unpacked" "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
for _icons in 16x16 32x32 64x64 128x128 256x256 512x512;do
install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
diff --git a/calmly-writer.sh b/calmly-writer.sh
index 43400f5ed0fb..006dab2a7a6f 100644
--- a/calmly-writer.sh
+++ b/calmly-writer.sh
@@ -1,6 +1,9 @@
-#!/bin/bash
+#!/bin/sh
_ELECTRON=/usr/bin/electron24
-_ASAR="/opt/calmly-writer/calmly-writer.asar"
+APPDIR="/usr/lib/calmly-writer"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else