summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrinceton Ferro2021-08-09 12:14:56 -0400
committerPrinceton Ferro2021-08-09 12:14:56 -0400
commit717cc467954aef8e80c90003d2cd1a1dd4dc89bd (patch)
treecc13bca4b6e519e1d00b567303827517a2ec5587
parentdc929321edacaba8e96d59a953d1874da1bd0ef6 (diff)
downloadaur-717cc467954aef8e80c90003d2cd1a1dd4dc89bd.tar.gz
Update to 0.7.0
Also get package version from git tag.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a70f9729479..22f4571a19ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cambalache-git
pkgdesc = A new RAD tool for Gtk 4 and 3 with a clear MVC design and data model first philosophy
- pkgver = 0.6.0
- pkgrel = 3
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://gitlab.gnome.org/jpu/cambalache
arch = any
license = LGPL
@@ -12,7 +12,7 @@ pkgbase = cambalache-git
depends = gtk3
depends = gtk4
depends = python-lxml
- provides = cambalache=0.6.0
+ provides = cambalache=0.7.0
conflicts = cambalache
source = git+https://gitlab.gnome.org/jpu/cambalache.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6cbbfac39651..7d1e053aa840 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Princeton Ferro (prince781) <princetonferro[at]gmail[dot]com)
+# Maintainer: Princeton Ferro (prince781) <princetonferro[at]gmail[dot]com>
pkgname=cambalache-git
_pkgname=cambalache
-pkgver=0.6.0
-pkgrel=3
+pkgver=0.7.0
+pkgrel=1
pkgdesc='A new RAD tool for Gtk 4 and 3 with a clear MVC design and data model first philosophy'
url=https://gitlab.gnome.org/jpu/cambalache
arch=(any)
@@ -15,10 +15,10 @@ provides=($_pkgname=$pkgver)
source=('git+https://gitlab.gnome.org/jpu/cambalache.git')
sha512sums=('SKIP')
-# pkgver() {
-# cd cambalache
-# git describe --tags | sed 's/-/./g'
-# }
+pkgver() {
+ cd cambalache
+ git describe --tags | sed 's/-/./g'
+}
build() {
arch-meson cambalache build