summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Luc2017-01-09 23:40:46 +1100
committerJean-Luc2017-01-09 23:41:28 +1100
commitbb136e97062bc3094e3e93528e34aa08e16482b6 (patch)
tree195b29e4d025def3295436582426ac94ea9da073
parent662cb21d7749a5a0a7a1dad66116b01f5d231ba6 (diff)
downloadaur-bb136e97062bc3094e3e93528e34aa08e16482b6.tar.gz
Removed `machine_cfg.py` as it's now in the git.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--machine_cfg.py84
3 files changed, 2 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2509bc866857..40b44515ba22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,9 +15,7 @@ pkgbase = camfr
depends = python2-imaging
depends = tk
source = git+https://github.com/jtambasco/camfr.git
- source = machine_cfg.py
md5sums = SKIP
- md5sums = db07413af39b15ff25d35b8dd89f2452
pkgname = camfr
diff --git a/PKGBUILD b/PKGBUILD
index 95c9d11fa551..acc37278b818 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,14 +15,11 @@ makedepends=('scons'
'gcc-fortran'
'openblas-lapack'
'blitz')
-source=('git+https://github.com/jtambasco/camfr.git'
- 'machine_cfg.py')
-md5sums=('SKIP'
- db07413af39b15ff25d35b8dd89f2452)
+source=('git+https://github.com/jtambasco/camfr.git')
+md5sums=('SKIP')
build() {
cd "${pkgname}"
- mv ../machine_cfg.py .
python2 setup.py build
}
diff --git a/machine_cfg.py b/machine_cfg.py
deleted file mode 100644
index 4acb1ad4e6a8..000000000000
--- a/machine_cfg.py
+++ /dev/null
@@ -1,84 +0,0 @@
-# This Python script contains all the machine dependent settings
-# needed during the build process.
-
-import sys
-import popen2, os
-
-# Get compiler flags from Gentoo's /etc/make.conf.
-
-r, w = popen2.popen2("source /etc/make.conf ; echo $CFLAGS")
-CXXFLAGS = r.readline().strip()
-r.close()
-w.close()
-
-# For gcc 4.2.1, filter the flags a bit.
-
-if "pentium-m" in CXXFLAGS or "pentium4" in CXXFLAGS:
- CXXFLAGS = CXXFLAGS.replace("-O3", "-O2")
-
-# Compilers to be used.
-
-cc = "gcc"
-cxx = "g++"
-f77 = "gfortran -fPIC" # Workaround for scons bug.
-
-# Compiler flags.
-#
-# Note: for the Fortran name definition you can define one of the following
-# preprocessor macros:
-#
-# FORTRAN_SYMBOLS_WITHOUT_TRAILING_UNDERSCORES
-# FORTRAN_SYMBOLS_WITH_SINGLE_TRAILING_UNDERSCORE
-# FORTRAN_SYMBOLS_WITH_DOUBLE_TRAILING_UNDERSCORES
-
-base_flags = "-DFORTRAN_SYMBOLS_WITH_SINGLE_TRAILING_UNDERSCORE -DNDEBUG "
-
-flags_noopt = base_flags
-
-flags = base_flags + " " + CXXFLAGS
-
-fflags = flags + " -fPIC "
-
-# Linker and linker flags to be used.
-
-link = cxx
-link_flags = ""
-
-# Include directories.
-
-include_dirs = []
-
-if os.path.isdir("/usr/include/python2.7"):
- include_dirs.append("/usr/include/python2.7")
- include_dirs.append("/usr/lib/python2.7/site-packages")
-elif os.path.isdir("/usr/include/python2.5"):
- include_dirs.append("/usr/include/python2.5")
- include_dirs.append("/usr/lib/python2.5/site-packages")
-elif os.path.isdir("/usr/include/python2.4"):
- include_dirs.append("/usr/include/python2.4")
- include_dirs.append("/usr/lib/python2.4/site-packages")
-elif os.path.isdir("/usr/include/python2.3"):
- include_dirs.append("/usr/include/python2.3")
- include_dirs.append("/usr/lib/python2.3/site-packages")
-else:
- print "Python dir not found!"
- sys.exit()
-
-# Library directories.
-
-library_dirs = []
-#library_dirs = ["/opt/intel/mkl8/lib/32"]
-
-# Library names.
-
-libs = ["boost_python", "blitz", "lapack", "blas", "gfortran"]
-#libs = ["boost_python", "blitz", "mkl_lapack64", "mkl", "gfortran"]
-
-# Command to strip library of excess symbols:
-
-dllsuffix = ".so"
-strip_command = "strip --strip-unneeded camfr/_camfr" + dllsuffix
-
-# Extra files to copy into installation directory.
-
-extra_files = [("doc", ["docs/camfr.pdf"])]