summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrern2023-01-22 03:25:16 +0000
committerrern2023-01-22 03:25:16 +0000
commit12c708b82d7071ce1ecdc33e62a1e142a1fa4e17 (patch)
tree834648949a25336b9235bb283fdb40eb196d19a3
parenta55cd42bac4ff03984a0ee8d8cc86eec79bfa8c1 (diff)
downloadaur-12c708b82d7071ce1ecdc33e62a1e142a1fa4e17.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
-rw-r--r--camilladsp.service15
-rw-r--r--camilladsp.yml56
4 files changed, 92 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f37e8b2a907..495027a4e482 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,12 +8,14 @@ pkgbase = camillagui-backend
license = GPL
source = https://github.com/HEnquist/camillagui-backend/archive/refs/tags/v1.0.0-rc5.tar.gz
source = camillagui.install
+ source = camilladsp.service
source = camillagui.service
- source = camillagui.yml
+ source = camilladsp.yml
sha256sums = dc2479998c8224077ba13be26e9ceca55b69731b12f14262c8e118c4d46ac23e
- sha256sums = 5f06cf681acd54f704f1e7dd0173dbbe5a003d453746323930cdb611c0bd0f27
+ sha256sums = fb782897a44cc26775b327d9b3f70364399f3b93149e621bf373dadb9161a046
+ sha256sums = 993f05f04e1627b1739046e3c59d880deec1d4849525fa0e633dda5493923b48
sha256sums = 816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240
- sha256sums = 15c0f36e5bebdfda8eb6d8cc5e34d8a6982a0b13eaf73f2d7478f48da1fe5587
+ sha256sums = ebc1207ffd8ae8339b2c22939f61d027485b286f4d402afca0a8a9930d5ea46f
pkgname = camillagui-backend
depends = camilladsp
diff --git a/PKGBUILD b/PKGBUILD
index 18e87f09e810..11d5ebc397d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,22 +9,23 @@ arch=(any)
license=(GPL)
source=(https://github.com/HEnquist/camillagui-backend/archive/refs/tags/v${pkgver/.rc/-rc}.tar.gz
camillagui.install
+ camilladsp.service
camillagui.service
- camillagui.yml)
+ camilladsp.yml)
sha256sums=('dc2479998c8224077ba13be26e9ceca55b69731b12f14262c8e118c4d46ac23e'
- '5f06cf681acd54f704f1e7dd0173dbbe5a003d453746323930cdb611c0bd0f27'
+ 'fb782897a44cc26775b327d9b3f70364399f3b93149e621bf373dadb9161a046'
+ '993f05f04e1627b1739046e3c59d880deec1d4849525fa0e633dda5493923b48'
'816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240'
- '15c0f36e5bebdfda8eb6d8cc5e34d8a6982a0b13eaf73f2d7478f48da1fe5587')
+ 'ebc1207ffd8ae8339b2c22939f61d027485b286f4d402afca0a8a9930d5ea46f')
install=camillagui.install
build() {
- installdir=$srcdir/srv/http/settings/camillagui
- mkdir -p $installdir $installdir/build
- bsdtar xf v${pkgver/.rc/-rc}.tar.gz --strip=1 -C $installdir
- rm $installdir/{.gitignore,*.md,*.txt}
- rm -rf $installdir/{.github,build}
- cp -f camillagui.yml $installdir/config
+ guidir=$srcdir/srv/http/settings/camillagui
+ mkdir -p $guidir
+ bsdtar xf v${pkgver/.rc/-rc}.tar.gz --strip=1 -C $guidir
+ rm $guidir/{.gitignore,*.md,*.txt}
+ rm -rf $guidir/{.github,build}
}
package() {
@@ -38,7 +39,10 @@ package() {
python-websocket-client
python-websockets
python-yaml)
- mv $srcdir/srv $pkgdir
- install -d $pkgdir/$installdir
- install -Dm 644 camillagui.service -t $pkgdir/usr/lib/systemd/system
+ dspdir=$pkgdir/srv/http/data/camilladsp
+ systemdir=$pkgdir/usr/lib/systemd/system
+ cp -rf $srcdir/srv $pkgdir
+ install -d $dspdir/{coeffs,configs} $systemdir
+ install -Dm 755 camilladsp.yml -t $dspdir/configs
+ install -Dm 644 camilladsp.service camillagui.service -t $systemdir
}
diff --git a/camilladsp.service b/camilladsp.service
new file mode 100644
index 000000000000..fd16f13d0b77
--- /dev/null
+++ b/camilladsp.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=CamillaDSP Daemon
+StartLimitIntervalSec=10
+StartLimitBurst=10
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/camilladsp /srv/http/data/camilladsp/configs/camilladsp.yml -p 1234 -o /var/log/camilladsp.log
+Restart=always
+RestartSec=1
+CPUSchedulingPolicy=fifo
+CPUSchedulingPriority=10
+
+[Install]
+WantedBy=multi-user.target
diff --git a/camilladsp.yml b/camilladsp.yml
new file mode 100644
index 000000000000..b3208d29047b
--- /dev/null
+++ b/camilladsp.yml
@@ -0,0 +1,56 @@
+---
+devices:
+ adjust_period: 10
+ capture:
+ channels: 2
+ device: hw:Loopback,0
+ format: S32LE
+ type: Alsa
+ capture_samplerate: 0
+ chunksize: 2048
+ enable_rate_adjust: false
+ enable_resampling: false
+ playback:
+ channels: 2
+ device: hw:0,0
+ format: S32LE
+ type: Alsa
+ queuelimit: 4
+ rate_measure_interval: 1
+ resampler_type: Synchronous
+ samplerate: 44100
+ silence_threshold: -60
+ silence_timeout: 3
+ stop_on_rate_change: false
+ target_level: 0
+filters:
+ Bass:
+ parameters:
+ freq: 85
+ gain: 0
+ q: 0.9
+ type: Lowshelf
+ type: Biquad
+ Treble:
+ parameters:
+ freq: 6500
+ gain: 0
+ q: 0.7
+ type: Highshelf
+ type: Biquad
+ Volume:
+ parameters:
+ ramp_time: 200
+ type: Volume
+mixers: {}
+pipeline:
+- channel: 0
+ names:
+ - Bass
+ - Treble
+ type: Filter
+- channel: 1
+ names:
+ - Bass
+ - Treble
+ type: Filter