summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrern2023-01-22 03:47:42 +0000
committerrern2023-01-22 03:47:42 +0000
commit6cbdcef5f541a70805afbf87152331f1f5cd1dee (patch)
treedc74b8b002e27402af123ad6d649f3131082c767
parent32dd743a5987b07da3cc3d2c8613314e378874db (diff)
downloadaur-6cbdcef5f541a70805afbf87152331f1f5cd1dee.tar.gz
update
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--camillagui.install57
3 files changed, 18 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40f88b7b94c0..37a08d2b5cf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = camillagui-backend
source = camillagui.service
source = camilladsp.yml
sha256sums = dc2479998c8224077ba13be26e9ceca55b69731b12f14262c8e118c4d46ac23e
- sha256sums = 2e9207b9bc015aa3773205f9a987aec86730926b941a148af44701104628d9cc
+ sha256sums = 3a6a5b684e586c031da289cfbd9a9590cee4d192f53e6d6ed6c0ea3d3fd5f719
sha256sums = 993f05f04e1627b1739046e3c59d880deec1d4849525fa0e633dda5493923b48
sha256sums = 816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240
sha256sums = ebc1207ffd8ae8339b2c22939f61d027485b286f4d402afca0a8a9930d5ea46f
diff --git a/PKGBUILD b/PKGBUILD
index 024a7e2a78f8..662a13f58106 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ source=(https://github.com/HEnquist/camillagui-backend/archive/refs/tags/v${pkgv
camillagui.service
camilladsp.yml)
sha256sums=('dc2479998c8224077ba13be26e9ceca55b69731b12f14262c8e118c4d46ac23e'
- '2e9207b9bc015aa3773205f9a987aec86730926b941a148af44701104628d9cc'
+ '3a6a5b684e586c031da289cfbd9a9590cee4d192f53e6d6ed6c0ea3d3fd5f719'
'993f05f04e1627b1739046e3c59d880deec1d4849525fa0e633dda5493923b48'
'816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240'
'ebc1207ffd8ae8339b2c22939f61d027485b286f4d402afca0a8a9930d5ea46f')
diff --git a/camillagui.install b/camillagui.install
index f25755ec86ac..40bb5e00c525 100644
--- a/camillagui.install
+++ b/camillagui.install
@@ -1,41 +1,11 @@
post_install() {
- sed -i '/^filters:/,$ d' /srv/http/data/camilladsp/configs/camilladsp.yml
- echo 'filters:
- Bass:
- parameters:
- freq: 85
- gain: 0
- q: 0.9
- type: Lowshelf
- type: Biquad
- Treble:
- parameters:
- freq: 6500
- gain: 0
- q: 0.7
- type: Highshelf
- type: Biquad
- Volume:
- parameters:
- ramp_time: 200
- type: Volume
-mixers: {}
-pipeline:
-- channel: 0
- names:
- - Bass
- - Treble
- type: Filter
-- channel: 1
- names:
- - Bass
- - Treble
- type: Filter' >> /srv/http/data/camilladsp/configs/camilladsp.yml
-
- cp -f /srv/http/data/camilladsp/configs/{camilladsp,default_config}.yml
- ln -sf /srv/http/data/camilladsp/configs/{camilladsp,active_config}.yml
+ dspdir=/srv/http/data/camilladsp/configs
+ guidir=/srv/http/settings/camillagui
- sed -i 's/"build")$/"build", follow_symlinks=True)/' /srv/http/settings/camillagui/backend/routes.py
+ cp -f $dspdir/{camilladsp,default_config}.yml
+ ln -s $dspdir/{camilladsp,active_config}.yml
+
+ sed -i 's/"build")$/"build", follow_symlinks=True)/' $guidir/backend/routes.py
sed -i -e '/cdsp.get_volume/ a\
elif name == "mute":\
@@ -48,11 +18,16 @@ pipeline:
' -e '/cdsp.set_volume/ a\
elif name == "mute":\
cdsp.set_mute(value == "true")
-' /srv/http/settings/camillagui/backend/views.py
+' $guidir/backend/views.py
+
+ sed -E -i -e 's|~/|/srv/http/data/|g
+' -e 's|(port: )5000|\15005|
+' -e 's|(symlink: )false|\1true|
+' -e 's|(on_set_active_config: ).*|\1"/srv/http/bash/settings/features.sh camilladspasound"|
+' $guidir/config/camillagui.yml
- sed -i 's/\(apply_config_automatically: \).*/\1true/' /srv/http/settings/camillagui/config/gui-config.yml
+ sed -i 's/\(apply_config_automatically: \).*/\1true/' $guidir/config/gui-config.yml
- mkdir /srv/http/data/camilladsp/coeffs
- chown -R http:http /srv/http/data/camilladsp /srv/http/settings/camillagui
- chmod -R 755 /srv/http/settings/camillagui
+ chown -R http:http $dspdir $guidir
+ chmod -R 755 $guidir
}