summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrern2023-01-21 15:02:23 +0000
committerrern2023-01-21 15:02:23 +0000
commita55cd42bac4ff03984a0ee8d8cc86eec79bfa8c1 (patch)
tree74e410e6e8ba9f13d29646c48a7e9271a7c33cee
parent65eba3b3792bc18f9ebf954bc846cba4e82ebfa2 (diff)
downloadaur-a55cd42bac4ff03984a0ee8d8cc86eec79bfa8c1.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--camillagui.install58
3 files changed, 63 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b13b4d6390d3..1f37e8b2a907 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = camillagui-backend
pkgdesc = Backend server for camillagui
- pkgver = 1.0.1
+ pkgver = 1.0.0.rc5
pkgrel = 1
url = https://github.com/HEnquist/camillagui-backend
install = camillagui.install
arch = any
license = GPL
- source = https://github.com/HEnquist/camillagui-backend/archive/refs/tags/v1.0.1.tar.gz
+ source = https://github.com/HEnquist/camillagui-backend/archive/refs/tags/v1.0.0-rc5.tar.gz
source = camillagui.install
source = camillagui.service
source = camillagui.yml
- sha256sums = 2ccdc4e8c2fdb2d22a952732dcfc95291b89e3d31c2f16d2ca479d06ad78e87a
- sha256sums = 369597094234c6c35dda241f91856befaadd6a937d8064e8802818d229d88d3e
+ sha256sums = dc2479998c8224077ba13be26e9ceca55b69731b12f14262c8e118c4d46ac23e
+ sha256sums = 5f06cf681acd54f704f1e7dd0173dbbe5a003d453746323930cdb611c0bd0f27
sha256sums = 816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240
sha256sums = 15c0f36e5bebdfda8eb6d8cc5e34d8a6982a0b13eaf73f2d7478f48da1fe5587
diff --git a/PKGBUILD b/PKGBUILD
index ec8587e39b49..18e87f09e810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: rern <rernrern@gmail.com>
pkgname=camillagui-backend
-pkgver=1.0.1
+pkgver=1.0.0.rc5
pkgrel=1
pkgdesc='Backend server for camillagui'
url=https://github.com/HEnquist/camillagui-backend
arch=(any)
license=(GPL)
-source=(https://github.com/HEnquist/camillagui-backend/archive/refs/tags/v$pkgver.tar.gz
+source=(https://github.com/HEnquist/camillagui-backend/archive/refs/tags/v${pkgver/.rc/-rc}.tar.gz
camillagui.install
camillagui.service
camillagui.yml)
-sha256sums=('2ccdc4e8c2fdb2d22a952732dcfc95291b89e3d31c2f16d2ca479d06ad78e87a'
- '369597094234c6c35dda241f91856befaadd6a937d8064e8802818d229d88d3e'
+sha256sums=('dc2479998c8224077ba13be26e9ceca55b69731b12f14262c8e118c4d46ac23e'
+ '5f06cf681acd54f704f1e7dd0173dbbe5a003d453746323930cdb611c0bd0f27'
'816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240'
'15c0f36e5bebdfda8eb6d8cc5e34d8a6982a0b13eaf73f2d7478f48da1fe5587')
@@ -24,7 +24,6 @@ build() {
bsdtar xf v${pkgver/.rc/-rc}.tar.gz --strip=1 -C $installdir
rm $installdir/{.gitignore,*.md,*.txt}
rm -rf $installdir/{.github,build}
- sed -i 's/"build")$/"build", follow_symlinks=True)/' $installdir/backend/routes.py
cp -f camillagui.yml $installdir/config
}
diff --git a/camillagui.install b/camillagui.install
index f44afb5cbd69..f25755ec86ac 100644
--- a/camillagui.install
+++ b/camillagui.install
@@ -1,6 +1,58 @@
post_install() {
- chown -R http:http srv/http/settings/camillagui
- chmod -R 755 srv/http/settings/camillagui
+ sed -i '/^filters:/,$ d' /srv/http/data/camilladsp/configs/camilladsp.yml
+ echo 'filters:
+ Bass:
+ parameters:
+ freq: 85
+ gain: 0
+ q: 0.9
+ type: Lowshelf
+ type: Biquad
+ Treble:
+ parameters:
+ freq: 6500
+ gain: 0
+ q: 0.7
+ type: Highshelf
+ type: Biquad
+ Volume:
+ parameters:
+ ramp_time: 200
+ type: Volume
+mixers: {}
+pipeline:
+- channel: 0
+ names:
+ - Bass
+ - Treble
+ type: Filter
+- channel: 1
+ names:
+ - Bass
+ - Treble
+ type: Filter' >> /srv/http/data/camilladsp/configs/camilladsp.yml
+
cp -f /srv/http/data/camilladsp/configs/{camilladsp,default_config}.yml
- ln -sf /srv/http/data/camilladsp/configs/camilladsp.yml srv/http/data/camilladsp/configs/active_config.yml
+ ln -sf /srv/http/data/camilladsp/configs/{camilladsp,active_config}.yml
+
+ sed -i 's/"build")$/"build", follow_symlinks=True)/' /srv/http/settings/camillagui/backend/routes.py
+
+ sed -i -e '/cdsp.get_volume/ a\
+ elif name == "mute":\
+ config = cdsp.get_config()\
+ mute = True if cdsp.get_mute() else False\
+ volume = cdsp.get_volume()\
+ result = {"config": config, "mute": mute, "volume": volume}\
+ return web.json_response(result)\
+
+' -e '/cdsp.set_volume/ a\
+ elif name == "mute":\
+ cdsp.set_mute(value == "true")
+' /srv/http/settings/camillagui/backend/views.py
+
+ sed -i 's/\(apply_config_automatically: \).*/\1true/' /srv/http/settings/camillagui/config/gui-config.yml
+
+ mkdir /srv/http/data/camilladsp/coeffs
+ chown -R http:http /srv/http/data/camilladsp /srv/http/settings/camillagui
+ chmod -R 755 /srv/http/settings/camillagui
}