summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrern2022-05-14 13:52:31 +0000
committerrern2022-05-14 13:52:31 +0000
commitf8dfcea52a6df3dd235a332f369388bc768348df (patch)
tree1d4d973227dbef622ea023d5703011aaf151c6f7
downloadaur-f8dfcea52a6df3dd235a332f369388bc768348df.tar.gz
Initial
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
-rw-r--r--camillagui.install4
-rw-r--r--camillagui.service9
-rwxr-xr-xcamillagui.yml14
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..603d58129467
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = camillagui-backend
+ pkgdesc = Backend server for camillagui
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/HEnquist/camillagui-backend
+ install = camillagui.install
+ arch = any
+ license = GPL
+ source = https://github.com/HEnquist/camillagui-backend/archive/refs/tags/v1.0.0-rc2.tar.gz
+ source = camillagui.install
+ source = camillagui.service
+ source = camillagui.yml
+ sha256sums = 33196444b920579b0e55ad9db8b676cc2d6237394d5ab9c5d363a4c1ce013b2a
+ sha256sums = c6786d57e06a59c204032358dec918b95a7a6c10a02956d37fcea92a5fdc7cd7
+ sha256sums = 816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240
+ sha256sums = 15c0f36e5bebdfda8eb6d8cc5e34d8a6982a0b13eaf73f2d7478f48da1fe5587
+
+pkgname = camillagui-backend
+ depends = camilladsp
+ depends = python-aiohttp
+ depends = python-jsonschema
+ depends = python-matplotlib
+ depends = python-numpy
+ depends = python-pycamilladsp
+ depends = python-pycamilladsp-plot
+ depends = python-websocket-client
+ depends = python-websockets
+ depends = python-yaml
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aeb3ac2623ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: rern <rernrern@gmail.com>
+
+pkgname=camillagui-backend
+pkgver=1.0.0
+pkgrc=-rc2
+pkgrel=1
+pkgdesc='Backend server for camillagui'
+url=https://github.com/HEnquist/camillagui-backend
+arch=(any)
+license=(GPL)
+install=camillagui.install
+source=(https://github.com/HEnquist/camillagui-backend/archive/refs/tags/v$pkgver$pkgrc.tar.gz
+ camillagui.install
+ camillagui.service
+ camillagui.yml)
+sha256sums=('33196444b920579b0e55ad9db8b676cc2d6237394d5ab9c5d363a4c1ce013b2a'
+ 'c6786d57e06a59c204032358dec918b95a7a6c10a02956d37fcea92a5fdc7cd7'
+ '816138c492d68e291375971a95f88e13d665a21e39202dfce7443c57b4d1d240'
+ '15c0f36e5bebdfda8eb6d8cc5e34d8a6982a0b13eaf73f2d7478f48da1fe5587')
+
+build() {
+ installdir=$srcdir/srv/http/settings/camillagui
+ mkdir -p $installdir
+ bsdtar xf v$pkgver$pkgrc.tar.gz --strip=1 -C $installdir
+ rm $installdir/{.gitignore,*.md,*.txt}
+ sed -i 's/"build")$/"build", follow_symlinks=True)/' $installdir/backend/routes.py
+ cp -f camillagui.yml $installdir/config
+}
+
+package() {
+ depends=(camilladsp
+ python-aiohttp
+ python-jsonschema
+ python-matplotlib
+ python-numpy
+ python-pycamilladsp
+ python-pycamilladsp-plot
+ python-websocket-client
+ python-websockets
+ python-yaml)
+ mv $srcdir/srv $pkgdir
+ install -d $pkgdir/$installdir
+ install -Dm 644 camillagui.service -t $pkgdir/usr/lib/systemd/system
+}
diff --git a/camillagui.install b/camillagui.install
new file mode 100644
index 000000000000..a6e592f87ab3
--- /dev/null
+++ b/camillagui.install
@@ -0,0 +1,4 @@
+post_install() {
+ chown -R http:http srv/http/settings/camillagui
+ chmod -R 755 srv/http/settings/camillagui
+}
diff --git a/camillagui.service b/camillagui.service
new file mode 100644
index 000000000000..026e60755c0d
--- /dev/null
+++ b/camillagui.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=CamillaDSP GUI
+
+[Service]
+Type=idle
+ExecStart=/usr/bin/python /srv/http/settings/camillagui/main.py
+
+[Install]
+WantedBy=multi-user.target
diff --git a/camillagui.yml b/camillagui.yml
new file mode 100755
index 000000000000..58a328ca6092
--- /dev/null
+++ b/camillagui.yml
@@ -0,0 +1,14 @@
+---
+camilla_host: "0.0.0.0"
+camilla_port: 1234
+port: 5005
+config_dir: "/srv/http/data/camilladsp/configs"
+coeff_dir: "/srv/http/data/camilladsp/coeffs"
+default_config: "/srv/http/data/camilladsp/configs/default_config.yml"
+active_config: "/srv/http/data/camilladsp/configs/active_config.yml"
+log_file: "/var/log/camilladsp.log"
+update_symlink: true
+on_set_active_config: "/srv/http/bash/settings/features.sh camilladspasound"
+on_get_active_config: null
+supported_capture_types: null
+supported_playback_types: null