summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfmount2017-10-19 12:04:31 +0200
committerfmount2017-10-19 12:04:31 +0200
commit023226a938dea9ab0358bf3d2fb0791b87ce9d1e (patch)
tree3c433862b5552661b4175a3ed9c72093d22d5bfa
downloadaur-camimporter.tar.gz
Uploading Camimporter package to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e372a1c0874d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = camimporter
+ pkgdesc = A useful tool to organize your multimedia files importing them from a generic CAMERA
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/fmount/camimporter.git
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python2-pillow
+ makedepends = python2-prettytable
+ makedepends = python2-six
+ makedepends = python2-setuptools
+ source = git://github.com/fmount/camimporter.git
+ md5sums = SKIP
+
+pkgname = camimporter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bbeb45fbd75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Francesco Pantano <fmount9@autistici.org>
+# Contributor: fmount
+
+pkgname=('camimporter')
+pkgver="0.1"
+pkgrel="1"
+pkgdesc="A useful tool to organize your multimedia files importing them from a generic CAMERA"
+arch=('i686' 'x86_64')
+url="https://github.com/fmount/${pkgname}.git"
+license=('MIT')
+makedepends=('python2-pillow' 'python2-prettytable' 'python2-six' 'python2-setuptools')
+source=("git://github.com/fmount/camimporter.git")
+#sha1sum=("SKIP")
+md5sums=('SKIP')
+
+build() {
+ echo "${srcdir}/${pkgname}"
+ cd "${srcdir}/$pkgname"
+ echo -e "camimporter version: $pkgver" > PKG-INFO
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ sudo python2 setup.py install --root="$pkgdir/"
+}