summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBertram Felgenhauer2016-10-27 11:17:24 +0200
committerSimon Legner2016-10-27 12:19:43 +0200
commit0fcd360b6f5ea9f629d3df4941755debec77144a (patch)
tree617b3a23f981069652d31ae936d22973e9b9f102
parent05b8fb73537b2d3063055f86aab956ea8c615ef1 (diff)
downloadaur-0fcd360b6f5ea9f629d3df4941755debec77144a.tar.gz
change installation patch of libraries to standard location
- the AUR package provides a META file for camlidl, and installs the camlidl libraries to a separate subdirectory in /usr/lib/ocaml - however, other distributions (e.g. debian) do not do this, so for compatibility, it's better to keep the default installation
-rw-r--r--PKGBUILD4
-rw-r--r--arch-build-system-fix.patch46
2 files changed, 34 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6089ac5fe4ae..2f2651e061bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,10 +39,10 @@ package() {
}
md5sums=('4cfb863bc3cbdc1af2502042c45cc675'
- '050c117fbddf73e7f7ca64cf1c17c644'
+ '9b7f92ec77b50d260b6487e4577bd5f0'
'162464cc1dfaf47019cbe2cef29bcab4'
'c8239780b7303f02b86ca6efc644640c')
sha1sums=('2a0d5ba70fea8c1de1c5387f8b2058357b2177df'
- 'a7869f04e83a279ad8327f7cade60b1e470cd24a'
+ 'b5cf6873bda3fe48f9946f09ccea39cd60fda59c'
'7665ee975581904ce605b1c006baa92189d7f3de'
'cdabd68036a1f52c8ba8cfb22bde5a034ff8b620')
diff --git a/arch-build-system-fix.patch b/arch-build-system-fix.patch
index 10fae0f1f917..8a65a3a3c0c1 100644
--- a/arch-build-system-fix.patch
+++ b/arch-build-system-fix.patch
@@ -1,7 +1,19 @@
-diff -Nur camlidl-1.05.orig/config/Makefile.unix camlidl-1.05/config/Makefile.unix
---- camlidl-1.05.orig/config/Makefile.unix 2013-10-02 11:39:13.596586957 +0200
-+++ camlidl-1.05/config/Makefile.unix 2013-10-02 11:40:06.050112149 +0200
-@@ -19,7 +19,7 @@
+From a29e6b96b4574be8eaeb8c9c7514583734108cae Mon Sep 17 00:00:00 2001
+From: Bertram Felgenhauer <int-e@gmx.de>
+Date: Thu, 27 Oct 2016 10:45:13 +0200
+Subject: [PATCH 1/2] arch build system fix
+
+---
+ config/Makefile.unix | 8 +++++---
+ lib/Makefile | 10 ++++++++--
+ runtime/Makefile.unix | 2 +-
+ 3 files changed, 14 insertions(+), 6 deletions(-)
+
+diff --git a/config/Makefile.unix b/config/Makefile.unix
+index cf4549c..fc8c063 100644
+--- a/config/Makefile.unix
++++ b/config/Makefile.unix
+@@ -19,7 +19,7 @@ OSTYPE=unix
# How to invoke the C preprocessor
# Works on most Unix systems:
@@ -10,13 +22,13 @@ diff -Nur camlidl-1.05.orig/config/Makefile.unix camlidl-1.05/config/Makefile.un
# Alternatives:
# CPP=cpp
# CPP=/usr/ccs/lib/cpp
-@@ -31,10 +31,12 @@
+@@ -31,10 +31,12 @@ RANLIB=ranlib
#RANLIB=:
# Location of the Objective Caml library in your installation
-OCAMLLIB=/usr/local/lib/ocaml
+OCAMLBASEDIR=$(shell ocamlc -where)
-+OCAMLLIB=$(DESTDIR)$(OCAMLBASEDIR)/camlidl
++OCAMLLIB=$(DESTDIR)$(OCAMLBASEDIR)
+OCAMLINCDIR=$(DESTDIR)$(OCAMLBASEDIR)/caml
# Where to install the binaries
@@ -25,10 +37,11 @@ diff -Nur camlidl-1.05.orig/config/Makefile.unix camlidl-1.05/config/Makefile.un
# The Objective Caml compilers (the defaults below should be OK)
OCAMLC=ocamlc -g
-diff -Nur camlidl-1.05.orig/lib/Makefile camlidl-1.05/lib/Makefile
---- camlidl-1.05.orig/lib/Makefile 2013-10-02 11:39:13.596586957 +0200
-+++ camlidl-1.05/lib/Makefile 2013-10-02 11:40:33.639866581 +0200
-@@ -29,8 +29,14 @@
+diff --git a/lib/Makefile b/lib/Makefile
+index 7ce04da..c347d6f 100644
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -29,8 +29,14 @@ $(NATIVELIB): $(NATIVEOBJS)
$(OCAMLOPT) -a -o $(NATIVELIB) $(NATIVEOBJS)
install:
@@ -45,10 +58,11 @@ diff -Nur camlidl-1.05.orig/lib/Makefile camlidl-1.05/lib/Makefile
.SUFFIXES: .mli .ml .cmi .cmo .cmx
-diff -Nur camlidl-1.05.orig/runtime/Makefile.unix camlidl-1.05/runtime/Makefile.unix
---- camlidl-1.05.orig/runtime/Makefile.unix 2013-10-02 11:39:13.596586957 +0200
-+++ camlidl-1.05/runtime/Makefile.unix 2013-10-02 11:39:21.178020877 +0200
-@@ -22,7 +22,7 @@
+diff --git a/runtime/Makefile.unix b/runtime/Makefile.unix
+index 5617349..737b048 100644
+--- a/runtime/Makefile.unix
++++ b/runtime/Makefile.unix
+@@ -22,7 +22,7 @@ libcamlidl.a: $(OBJS)
$(RANLIB) $@
install:
@@ -56,3 +70,7 @@ diff -Nur camlidl-1.05.orig/runtime/Makefile.unix camlidl-1.05/runtime/Makefile.
+ cp camlidlruntime.h $(OCAMLINCDIR)/camlidlruntime.h
cp libcamlidl.a $(OCAMLLIB)/libcamlidl.a
cd $(OCAMLLIB); $(RANLIB) libcamlidl.a
+
+--
+2.10.1
+