summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2015-06-12 11:02:43 +0200
committerSimon Legner2015-06-12 11:02:43 +0200
commite23565c983c21f60787b6ba027c08ff81564246a (patch)
tree439f984577ae6e0259192079c1850f35f26abc91
downloadaur-e23565c983c21f60787b6ba027c08ff81564246a.tar.gz
Initial import
-rw-r--r--.AURINFO22
-rw-r--r--.SRCINFO22
-rw-r--r--META.camlidl4
-rw-r--r--PKGBUILD44
-rw-r--r--arch-build-system-fix.patch58
5 files changed, 150 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..9b26102f48d1
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,22 @@
+pkgbase = camlidl
+ pkgdesc = A stub code generator and COM binding for Objective Caml (OCaml)
+ pkgver = 1.05
+ pkgrel = 5
+ url = http://caml.inria.fr/pub/old_caml_site/camlidl/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = ocaml
+ options = staticlibs
+ source = http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/camlidl-1.05.tar.gz
+ source = arch-build-system-fix.patch
+ source = META.camlidl
+ md5sums = 4cfb863bc3cbdc1af2502042c45cc675
+ md5sums = 050c117fbddf73e7f7ca64cf1c17c644
+ md5sums = c8239780b7303f02b86ca6efc644640c
+ sha1sums = 2a0d5ba70fea8c1de1c5387f8b2058357b2177df
+ sha1sums = a7869f04e83a279ad8327f7cade60b1e470cd24a
+ sha1sums = cdabd68036a1f52c8ba8cfb22bde5a034ff8b620
+
+pkgname = camlidl
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b26102f48d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = camlidl
+ pkgdesc = A stub code generator and COM binding for Objective Caml (OCaml)
+ pkgver = 1.05
+ pkgrel = 5
+ url = http://caml.inria.fr/pub/old_caml_site/camlidl/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = ocaml
+ options = staticlibs
+ source = http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/camlidl-1.05.tar.gz
+ source = arch-build-system-fix.patch
+ source = META.camlidl
+ md5sums = 4cfb863bc3cbdc1af2502042c45cc675
+ md5sums = 050c117fbddf73e7f7ca64cf1c17c644
+ md5sums = c8239780b7303f02b86ca6efc644640c
+ sha1sums = 2a0d5ba70fea8c1de1c5387f8b2058357b2177df
+ sha1sums = a7869f04e83a279ad8327f7cade60b1e470cd24a
+ sha1sums = cdabd68036a1f52c8ba8cfb22bde5a034ff8b620
+
+pkgname = camlidl
+
diff --git a/META.camlidl b/META.camlidl
new file mode 100644
index 000000000000..4629e598ff31
--- /dev/null
+++ b/META.camlidl
@@ -0,0 +1,4 @@
+description = "Stub generator"
+version = "1.05"
+archive(byte) = "com.cma"
+archive(native) = "com.cmxa" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..192f4e849eb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
+# Contributor: Jakob Nixdorf <flocke@shadowice.org>
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=camlidl
+pkgver=1.05
+pkgrel=5
+pkgdesc="A stub code generator and COM binding for Objective Caml (OCaml)"
+arch=('i686' 'x86_64')
+url="http://caml.inria.fr/pub/old_caml_site/camlidl/"
+license=('custom')
+depends=('ocaml')
+options=(staticlibs)
+source=(http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/$pkgname-$pkgver.tar.gz
+ arch-build-system-fix.patch
+ META.camlidl)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -Np1 -i ${srcdir}/arch-build-system-fix.patch
+
+ cp config/Makefile.unix config/Makefile
+
+ make all
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ local _ocamldir=$(ocamlc -where)
+ mkdir -p ${pkgdir}/usr/bin ${pkgdir}/${_ocamldir}/{caml,${pkgname}}
+
+ make DESTDIR=${pkgdir} install
+
+ install -Dm644 ${srcdir}/META.camlidl ${pkgdir}/${_ocamldir}/${pkgname}/META
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums=('4cfb863bc3cbdc1af2502042c45cc675'
+ '050c117fbddf73e7f7ca64cf1c17c644'
+ 'c8239780b7303f02b86ca6efc644640c')
+sha1sums=('2a0d5ba70fea8c1de1c5387f8b2058357b2177df'
+ 'a7869f04e83a279ad8327f7cade60b1e470cd24a'
+ 'cdabd68036a1f52c8ba8cfb22bde5a034ff8b620')
diff --git a/arch-build-system-fix.patch b/arch-build-system-fix.patch
new file mode 100644
index 000000000000..10fae0f1f917
--- /dev/null
+++ b/arch-build-system-fix.patch
@@ -0,0 +1,58 @@
+diff -Nur camlidl-1.05.orig/config/Makefile.unix camlidl-1.05/config/Makefile.unix
+--- camlidl-1.05.orig/config/Makefile.unix 2013-10-02 11:39:13.596586957 +0200
++++ camlidl-1.05/config/Makefile.unix 2013-10-02 11:40:06.050112149 +0200
+@@ -19,7 +19,7 @@
+
+ # How to invoke the C preprocessor
+ # Works on most Unix systems:
+-CPP=/lib/cpp
++CPP=$(shell which cpp)
+ # Alternatives:
+ # CPP=cpp
+ # CPP=/usr/ccs/lib/cpp
+@@ -31,10 +31,12 @@
+ #RANLIB=:
+
+ # Location of the Objective Caml library in your installation
+-OCAMLLIB=/usr/local/lib/ocaml
++OCAMLBASEDIR=$(shell ocamlc -where)
++OCAMLLIB=$(DESTDIR)$(OCAMLBASEDIR)/camlidl
++OCAMLINCDIR=$(DESTDIR)$(OCAMLBASEDIR)/caml
+
+ # Where to install the binaries
+-BINDIR=/usr/local/bin
++BINDIR=$(DESTDIR)/usr/bin
+
+ # The Objective Caml compilers (the defaults below should be OK)
+ OCAMLC=ocamlc -g
+diff -Nur camlidl-1.05.orig/lib/Makefile camlidl-1.05/lib/Makefile
+--- camlidl-1.05.orig/lib/Makefile 2013-10-02 11:39:13.596586957 +0200
++++ camlidl-1.05/lib/Makefile 2013-10-02 11:40:33.639866581 +0200
+@@ -29,8 +29,14 @@
+ $(OCAMLOPT) -a -o $(NATIVELIB) $(NATIVEOBJS)
+
+ install:
+- cp $(INTERFACES) $(BYTELIB) $(NATIVELIB) $(NATIVELIB:.cmxa=.$(LIBEXT)) $(OCAMLLIB)
+- cd $(OCAMLLIB); $(RANLIB) $(NATIVELIB:.cmxa=.$(LIBEXT))
++ cp $(INTERFACES) $(BYTELIB) $(OCAMLLIB)
++ if [ -x /usr/bin/ocamlopt ]; then \
++ cp $(NATIVELIB) $(NATIVELIB:.cmxa=.$(LIBEXT)) $(OCAMLLIB); \
++ cd $(OCAMLLIB); \
++ $(RANLIB) $(NATIVELIB:.cmxa=.$(LIBEXT)); \
++ else \
++ true; \
++ fi
+
+ .SUFFIXES: .mli .ml .cmi .cmo .cmx
+
+diff -Nur camlidl-1.05.orig/runtime/Makefile.unix camlidl-1.05/runtime/Makefile.unix
+--- camlidl-1.05.orig/runtime/Makefile.unix 2013-10-02 11:39:13.596586957 +0200
++++ camlidl-1.05/runtime/Makefile.unix 2013-10-02 11:39:21.178020877 +0200
+@@ -22,7 +22,7 @@
+ $(RANLIB) $@
+
+ install:
+- cp camlidlruntime.h $(OCAMLLIB)/caml/camlidlruntime.h
++ cp camlidlruntime.h $(OCAMLINCDIR)/camlidlruntime.h
+ cp libcamlidl.a $(OCAMLLIB)/libcamlidl.a
+ cd $(OCAMLLIB); $(RANLIB) libcamlidl.a