summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPoroing2016-08-25 11:04:51 +0200
committerPoroing2016-08-25 11:04:51 +0200
commit6877a212bca5cc3ea356e0ee7e32774c83dfea97 (patch)
treeda0b6ae44123e93964a8b24421b55a828963f421
downloadaur-6877a212bca5cc3ea356e0ee7e32774c83dfea97.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD55
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4260c205b9e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = camllight
+ pkgdesc = Compiler for caml light source code
+ pkgver = 0.75
+ pkgrel = 1
+ url = http://caml.inria.fr/
+ arch = i686
+ arch = x86_64
+ license = custom:INRIA
+ makedepends = gcc
+ makedepends = sh
+ depends = sh
+ source = http://caml.inria.fr/pub/distrib/caml-light-0.75//cl75unix.tar.gz
+ md5sums = 6c236074e4487949ec22001c7a498057
+
+pkgname = camllight
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f809f98064dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jean Jouve <jean-18-09@hotmail.fr>
+pkgname=camllight
+pkgver=0.75
+pkgrel=1
+pkgdesc="Compiler for caml light source code"
+arch=('i686' 'x86_64')
+url='http://caml.inria.fr/'
+license=('custom:INRIA')
+depends=('sh')
+makedepends=('gcc' 'sh')
+source=('http://caml.inria.fr/pub/distrib/caml-light-0.75//cl75unix.tar.gz')
+md5sums=('6c236074e4487949ec22001c7a498057')
+validpgpkeys=()
+
+build() {
+ cd 'cl75/src'
+ make BINDIR="/usr/bin/"\
+ LIBDIR="/usr/lib/caml-light"\
+ MANDIR="/usr/share/man/man1"\
+ CPP="/usr/bin/cpp -P -traditional -Dunix"\
+ configure
+ make BINDIR="/usr/bin/"\
+ LIBDIR="/usr/lib/caml-light"\
+ MANDIR="/usr/share/man/man1"\
+ CPP="/usr/bin/cpp -P -traditional -Dunix"\
+ world
+}
+
+check() {
+ cd 'cl75/src'
+ make BINDIR="/usr/bin/"\
+ LIBDIR="/usr/lib/caml-light"\
+ MANDIR="/usr/share/man/man1"\
+ CPP="/usr/bin/cpp -P -traditional -Dunix"\
+ bootstrap
+}
+
+package() {
+ #make install doesn't create any of the required directory
+ mkdir -p $pkgdir/usr/bin/
+ mkdir -p $pkgdir/usr/lib/caml-light
+ mkdir -p $pkgdir/usr/share/man/man1
+
+ #Install the license
+ cd 'cl75'
+ install -D -m644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ #Install camllight
+ cd 'src'
+ make BINDIR="$pkgdir/usr/bin/"\
+ LIBDIR="$pkgdir/usr/lib/caml-light"\
+ MANDIR="$pkgdir/usr/share/man/man1"\
+ CPP="/usr/bin/cpp -P -traditional -Dunix"\
+ install
+}