summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Bandel2015-06-10 00:29:57 +0200
committerOliver Bandel2015-06-10 00:29:57 +0200
commita5cefd20bee2f2887da1352e00ce816673c3b82d (patch)
tree69bdcf732a1288f7fa050455fb726c675d85bcdb
downloadaur-a5cefd20bee2f2887da1352e00ce816673c3b82d.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b007cef1e16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = camlpdf
+ pkgdesc = PDF-processing-library for OCaml
+ pkgver = 2.1.1
+ pkgrel = 2
+ url = https://github.com/johnwhitington/camlpdf
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = ocaml-findlib
+ depends = glibc
+ options = !makeflags
+ options = staticlibs
+ source = https://github.com/johnwhitington/camlpdf/archive/v2.1.1.tar.gz
+ md5sums = a3df80d071cc8d13ed119f9826941361
+
+pkgname = camlpdf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..660fb5660447
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: oliver < a t > first . in-berlin . de
+pkgname=camlpdf
+pkgver=2.1.1
+pkgrel=2
+pkgdesc="PDF-processing-library for OCaml"
+arch=('i686' 'x86_64')
+license=('LGPL')
+source=(https://github.com/johnwhitington/camlpdf/archive/v$pkgver.tar.gz)
+md5sums=('a3df80d071cc8d13ed119f9826941361')
+url="https://github.com/johnwhitington/camlpdf"
+depends=('glibc')
+makedepends=('ocaml-findlib')
+options=(!makeflags staticlibs)
+#
+build() {
+cd ${srcdir}/camlpdf-$pkgver
+#
+OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
+make OCAMLFIND_DESTDIR="${OCAMLFIND_DESTDIR}"
+}
+#
+#
+package() {
+cd ${srcdir}/camlpdf-$pkgver
+#
+OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
+mkdir -p ${OCAMLFIND_DESTDIR}
+#
+OCAMLFIND_LDCONF="$pkgdir/$(ocamlfind printconf ldconf)"
+#
+make install -d OCAMLFIND_DESTDIR="${OCAMLFIND_DESTDIR}" OCAMLFIND_LDCONF="${OCAMLFIND_LDCONF}"
+}