summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin R. St-Amant2015-08-10 19:37:31 -0500
committerJustin R. St-Amant2015-08-10 19:37:31 -0500
commit21201227978f39776fcf7c7eb021f7dccef7f339 (patch)
tree345fb479fb56e9c3d9090693a7cf704717776daa
downloadaur-21201227978f39776fcf7c7eb021f7dccef7f339.tar.gz
Created package from scratch, and took up it's ownership
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d048c6e660f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = cammill-git
+ pkgdesc = CAM application to produce tool paths and gcode from DXF files
+ pkgver = 0.9.test.17.r62.gf6fe006
+ pkgrel = 1
+ url = https://github.com/cammill/cammill
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ checkdepends = cppcheck
+ makedepends = clang
+ makedepends = git
+ depends = freeglut
+ depends = glib2
+ depends = gtkglext
+ depends = gtksourceview2
+ depends = gtk2
+ depends = lua51
+ provides = cammill
+ source = git+https://github.com/cammill/cammill.git
+ md5sums = SKIP
+
+pkgname = cammill-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ce0e6fd1005
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Justin R. St-Amant <jstamant24 at gmail dot com>
+
+pkgname=cammill-git
+pkgver=0.9.test.17.r62.gf6fe006
+pkgrel=1
+pkgdesc="CAM application to produce tool paths and gcode from DXF files"
+arch=('i686' 'x86_64')
+url="https://github.com/cammill/cammill"
+license=('GPL3')
+depends=('freeglut'
+ 'glib2'
+ 'gtkglext'
+ 'gtksourceview2'
+ 'gtk2'
+ 'lua51')
+makedepends=('clang' 'git')
+checkdepends=('cppcheck')
+provides=('cammill')
+source=("git+https://github.com/cammill/cammill.git")
+md5sums=('SKIP')
+
+_gitroot=https://github.com/cammill/cammill.git
+_gitname=cammill
+
+pkgver()
+{
+ cd $_gitname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build()
+{
+ cd $srcdir/$_gitname
+ make clean all
+}
+
+check()
+{
+ cd $srcdir/$_gitname
+ make check
+}
+
+package()
+{
+ cd $srcdir/$_gitname
+ make INSTALL_PATH="$pkgdir/usr" install
+}