summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Klevtsov2020-12-27 16:34:28 +0700
committerArtem Klevtsov2020-12-27 16:34:28 +0700
commit217a9f253e2c67e8e63cfc2f6356cb9271bccaae (patch)
tree7893ddc3d500d6559da682e3d7f28e16081fe33f
downloadaur-217a9f253e2c67e8e63cfc2f6356cb9271bccaae.tar.gz
Init package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d39d6e4c764
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = camomile-git
+ pkgdesc = Camomile is a plugin with Pure Data embedded that offers to load and to control patches inside a digital audio workstation
+ pkgver = 1.0.7
+ pkgrel = 1
+ url = https://github.com/pierreguillot/Camomile
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = libx11
+ makedepends = libxrandr
+ makedepends = libxinerama
+ makedepends = libxcursor
+ makedepends = alsa-lib
+ depends = freetype2
+ conflicts = camomile
+ replaces = camomile
+ source = git+https://github.com/pierreguillot/Camomile/
+ sha512sums = SKIP
+
+pkgname = camomile-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afd206d638de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Artem Klevtsov a.a.klevtsov@gmail.com
+
+pkgname='camomile-git'
+pkgdesc='Camomile is a plugin with Pure Data embedded that offers to load and to control patches inside a digital audio workstation'
+pkgver=1.0.7
+pkgrel=1
+depends=('freetype2')
+makedepends=('git' 'libx11' 'libxrandr' 'libxinerama' 'libxcursor' 'alsa-lib')
+optdepends=()
+conflicts=('camomile')
+replaces=('camomile')
+arch=('x86_64')
+url='https://github.com/pierreguillot/Camomile'
+license=('GPL3')
+source=("git+https://github.com/pierreguillot/Camomile/")
+sha512sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/Camomile"
+ git submodule update --init --recursive
+}
+
+build () {
+ cd "${srcdir}/Camomile"
+ cd Dependencies/LibPdBuild/LinuxMakefile
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+
+ cd "${srcdir}/Camomile"
+ make TARGET_ARCH=-m64 CONFIG=Release
+}
+
+package () {
+ cd "${srcdir}/Camomile"
+ mkdir -p "${pkgdir}/usr/lib/lv2/"
+ mkdir -p "${pkgdir}/usr/lib/vst3"
+
+ mkdir -p "${pkgdir}/usr/lib/lv2/Camomile.lv2"
+ cp -a Plugins/CamomileLV2.so "${pkgdir}/usr/lib/lv2/Camomile.lv2"
+ cp -ar Plugins/Camomile.vst3 "${pkgdir}/usr/lib/vst3/"
+ cp -ar Plugins/CamomileFx.vst3 "${pkgdir}/usr/lib/vst3/"
+
+ # find Plugins/Builds -name '*.lv2' -type d -exec cp -ar {} "${pkgdir}/usr/lib/lv2/" \;
+ # find Plugins/Builds -name '*.vst3' -type d -exec cp -ar {} "${pkgdir}/usr/lib/vst3/" \;
+}