summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Hentschel (hpmachining)2022-03-12 13:05:31 -0500
committerPaul Hentschel (hpmachining)2022-03-12 13:05:31 -0500
commit42869be4de9c51f50e69e1c78281a1ea0b23f37b (patch)
tree4b344d4f7ad9bfe5ba045887577439d7d5f0d199
parent99e1fcd6b0f0c322a93ed4b508c826b1196104f8 (diff)
downloadaur-42869be4de9c51f50e69e1c78281a1ea0b23f37b.tar.gz
Updated for latest scons version (4.3.0)
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--0001_python3_and_scons.patch (renamed from 0001_python3_fix.patch)21
-rw-r--r--PKGBUILD8
4 files changed, 23 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5789b7e2b4e1..b62dba405561 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = camotics
pkgdesc = 3-axis NC machining simulation software
pkgver = 1.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://camotics.org/
arch = x86_64
license = GPL2
@@ -14,9 +14,8 @@ pkgbase = camotics
depends = cairo
depends = desktop-file-utils
source = camotics-1.2.0.tar.gz::https://github.com/CauldronDevelopmentLLC/camotics/archive/v1.2.0.tar.gz
- source = 0001_python3_fix.patch
+ source = 0001_python3_and_scons.patch
sha256sums = f5203d2bbd32c4e347a8f79122e57b2deea68e6c5bd4f0be4087c4d62a31c8a4
- sha256sums = 20ddecce61f6df4c10ca80d08c99762099eaea7ff574e3f11f57435c9e504e4b
+ sha256sums = 9cf14a78378dcdca27d1116adbd56a58059d826c776748094f5c0f8272465ed4
pkgname = camotics
-
diff --git a/.gitignore b/.gitignore
index 5efe81dedfda..7735b4612827 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,4 @@
!PKGBUILD
!.SRCINFO
!.gitignore
-!0001_python3_fix.patch
+!*.patch
diff --git a/0001_python3_fix.patch b/0001_python3_and_scons.patch
index 1876c5d4e74e..a7822de05850 100644
--- a/0001_python3_fix.patch
+++ b/0001_python3_and_scons.patch
@@ -1,18 +1,19 @@
-diff -ruN a/config/qt5/__init__.py b/config/qt5/__init__.py
--- a/config/qt5/__init__.py 2019-02-09 03:42:39.000000000 -0500
-+++ b/config/qt5/__init__.py 2019-08-18 17:14:51.786563078 -0400
-@@ -42,6 +42,11 @@
++++ b/config/qt5/__init__.py 2022-03-12 12:05:18.481925020 -0500
+@@ -42,7 +42,12 @@
import SCons.Util
+-class ToolQt5Warning(SCons.Warnings.Warning): pass
+def _bytes_to_str(s):
+ if isinstance(s, bytes): return s.decode()
+ return s
+
+
- class ToolQt5Warning(SCons.Warnings.Warning): pass
++class ToolQt5Warning(SCons.Warnings.SConsWarning): pass
class GeneratedMocFileNotIncluded(ToolQt5Warning): pass
class QtdirNotFound(ToolQt5Warning): pass
+
@@ -187,7 +192,7 @@
if moc_options['debug']:
print("scons: qt5: Scanning '%s' (header of '%s')" %
@@ -58,6 +59,15 @@ diff -ruN a/config/qt5/__init__.py b/config/qt5/__init__.py
includes = qrcinclude_re.findall(contents)
qrcpath = os.path.dirname(node.path)
dirs = [included for included in includes if
+@@ -751,7 +758,7 @@
+ QT5_MOCDEFPREFIX = '-D',
+ QT5_MOCDEFSUFFIX = '',
+ QT5_MOCDEFINES = '${_defines(QT5_MOCDEFPREFIX, CPPDEFINES, '
+- 'QT5_MOCDEFSUFFIX, __env__)}',
++ 'QT5_MOCDEFSUFFIX, __env__, TARGET, SOURCE)}',
+ QT5_MOCCPPPATH = [],
+ QT5_MOCINCFLAGS = '$( ${_concat(QT5_MOCINCPREFIX, QT5_MOCCPPPATH, '
+ 'INCSUFFIX, __env__, RDirs)} $)',
@@ -932,7 +939,7 @@
except: pass
@@ -67,9 +77,8 @@ diff -ruN a/config/qt5/__init__.py b/config/qt5/__init__.py
if debug : debugSuffix = '_debug'
for module in modules :
if module not in pclessModules : continue
-diff -ruN a/SConstruct b/SConstruct
--- a/SConstruct 2019-02-09 03:42:39.000000000 -0500
-+++ b/SConstruct 2019-08-18 16:58:35.889914920 -0400
++++ b/SConstruct 2022-03-12 12:03:04.921922687 -0500
@@ -48,7 +48,7 @@
lines += os.popen('svn status -v cbang').readlines()
lines = filter(lambda l: len(l) and l[0] in 'MA ', lines)
diff --git a/PKGBUILD b/PKGBUILD
index 64c31bcc94a2..135f5adf197e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=camotics
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="3-axis NC machining simulation software"
arch=('x86_64')
url="https://camotics.org/"
@@ -22,14 +22,14 @@ makedepends=(
)
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/CauldronDevelopmentLLC/$pkgname/archive/v$pkgver.tar.gz"
- "0001_python3_fix.patch"
+ "0001_python3_and_scons.patch"
)
sha256sums=('f5203d2bbd32c4e347a8f79122e57b2deea68e6c5bd4f0be4087c4d62a31c8a4'
- '20ddecce61f6df4c10ca80d08c99762099eaea7ff574e3f11f57435c9e504e4b')
+ 'efd61c32d9adffffe73672effbcdcedcedcc14693c797ac4d93574ac4e20c1b9')
prepare() {
cd "CAMotics-$pkgver"
- patch -p1 -i "../0001_python3_fix.patch"
+ patch -p1 -i "../0001_python3_and_scons.patch"
}
build() {