summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Nielsen2015-06-27 19:42:02 +1000
committerAdam Nielsen2015-06-27 19:42:02 +1000
commita093310d1f1a17e26d8183878a765d64d668e294 (patch)
treecfee6a6e7296fe7dffdd3e99ab2c2e39e45a95fb
downloadaur-a093310d1f1a17e26d8183878a765d64d668e294.tar.gz
Import to AUR4
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD72
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..995fa96502fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = camoto-studio-git
+ pkgdesc = Examine and edit DOS games
+ pkgver = 20120611
+ pkgrel = 1
+ url = http://www.shikadi.net/camoto
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = pkgconfig
+ depends = boost
+ depends = png++
+ depends = libgamecommon
+ depends = libgamearchive
+ depends = libgamegraphics
+ depends = libgamemaps
+ depends = libgamemusic
+ depends = wxgtk
+ provides = camoto-studio
+ conflicts = camoto-studio
+
+pkgname = camoto-studio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..546d58b4eb35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Adam Nielsen <malvineous@shikadi.net>
+
+_pkgname=camoto-studio
+pkgname=${_pkgname}-git
+pkgver=20120611
+pkgrel=1
+pkgdesc="Examine and edit DOS games"
+arch=('i686' 'x86_64')
+url="http://www.shikadi.net/camoto"
+license=('GPL3')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=(
+ 'boost'
+ 'png++'
+ 'libgamecommon'
+ 'libgamearchive'
+ 'libgamegraphics'
+ 'libgamemaps'
+ 'libgamemusic'
+ 'wxgtk'
+)
+makedepends=('git' 'autoconf' 'automake' 'pkgconfig')
+options=()
+_gitname=${_pkgname}
+_gitroot="git://github.com/Malvineous/${_gitname}"
+source=()
+md5sums=()
+
+build() {
+ cd "${srcdir}"
+
+ if [ "$NOEXTRACT" -eq 0 ]; then
+ if [ -d "$_gitname" ]; then
+ cd "$_gitname"
+
+ msg "Cleaning up from previous build."
+ git clean -X -f
+
+ msg "Reverting local changes to source tree..."
+ git reset --hard
+
+ msg "Updating from GitHub server..."
+ git pull origin
+ msg "The local files are updated."
+ else
+ msg "Downloading from GitHub server..."
+ git clone --depth=1 -- "$_gitroot" "$_gitname"
+ cd "$_gitname"
+ fi
+ else
+ warning "Skipping git clean/pull -- using existing src/ tree"
+ cd "$_gitname"
+ fi
+
+ msg "Configuring build environment..."
+ ./autogen.sh
+ ./configure --prefix="/usr"
+
+ msg "Beginning compile..."
+ make ${MAKEFLAGS}
+}
+
+check() {
+ cd "$srcdir/$_gitname"
+ make ${MAKEFLAGS} check
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make install DESTDIR="$pkgdir"
+}