summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Büchau2020-09-02 18:36:04 +0200
committerYann Büchau2020-09-02 18:36:04 +0200
commit19ec40a92cb942ed30540147945cc1dd61fb13e0 (patch)
treeb25ccdc689d71a722fbaa361e6f0685a3605f733
downloadaur-19ec40a92cb942ed30540147945cc1dd61fb13e0.tar.gz
Initial version
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..220f29a79570
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = camp2ascii-git
+ pkgdesc = Convert Campbell Scientific TOB3 files to other formats
+ pkgver = r16.0f9d0a3
+ pkgrel = 1
+ url = https://github.com/nobodyinperson/camp2ascii
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ makedepends = git
+ provides = camp2ascii
+ conflicts = camp2ascii
+ source = git+https://github.com/nobodyinperson/camp2ascii
+ md5sums = SKIP
+
+pkgname = camp2ascii-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..01e06b45b4fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.?z
+pkg/
+src/
+camp2ascii/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed7154241bb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Yann Büchau <nobodyinperson@posteo.de>
+pkgname=camp2ascii-git
+pkgver=r16.0f9d0a3
+pkgrel=1
+pkgdesc="Convert Campbell Scientific TOB3 files to other formats"
+arch=('x86_64' 'aarch64')
+url="https://github.com/nobodyinperson/camp2ascii"
+license=('GPL')
+groups=()
+depends=()
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/nobodyinperson/camp2ascii')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -m755 bin/camp2ascii -D -t $pkgdir/usr/bin/
+}