summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2021-06-26 16:41:44 +0200
committerPhilipp A2021-06-26 16:41:44 +0200
commit7a6c152011b2fb591db8b652899ee99d1b7382b7 (patch)
treeeb453aa5e9d3cbe87f7603682370e7fcdafad78e
downloadaur-7a6c152011b2fb591db8b652899ee99d1b7382b7.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..384432a60c10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = camset
+ pkgdesc = GUI for v4l2-ctl
+ pkgver = 0.0.13
+ pkgrel = 1
+ url = https://github.com/azeam/camset
+ arch = any
+ license = GPL3
+ makedepends = install-wheel-scripts
+ depends = python
+ depends = python-opencv
+ depends = python-gobject
+ depends = v4l-utils
+ depends = pkgconf
+ provides = camset
+ provides = python-camset
+ noextract = camset-0.0.13-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/c/camset/camset-0.0.13-py3-none-any.whl
+ sha256sums = 09bc128890c7f6567198a672887b6999ac16d3b6a7b312db57974bdb4fe33cc5
+
+pkgname = camset
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb3cc40a81f9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.tar.xz
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bf4ccea9cd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+pkgname=camset
+pkgver=0.0.13
+pkgrel=1
+pkgdesc='GUI for v4l2-ctl'
+arch=(any)
+provides=($pkgname python-$pkgname)
+url="https://github.com/azeam/$pkgname"
+license=(GPL3)
+depends=(python python-opencv python-gobject v4l-utils pkgconf)
+makedepends=(install-wheel-scripts)
+_wheel="$pkgname-$pkgver-py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
+sha256sums=('09bc128890c7f6567198a672887b6999ac16d3b6a7b312db57974bdb4fe33cc5')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ install -d "$site"
+ unzip "$_wheel" -d "$site"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
+}