summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnrico Pozzobon2018-07-24 12:20:56 +0200
committerEnrico Pozzobon2018-07-24 12:20:56 +0200
commit28f1db6aa4e1aba46ebc262917f6b6f5fd19a686 (patch)
tree5061babeff63ae0cbc9dad9950722d693511d9eb
parent0b75c90dab4ad196ac78bec3b35a043e4caaeae8 (diff)
downloadaur-28f1db6aa4e1aba46ebc262917f6b6f5fd19a686.tar.gz
Added Makefile patch for dkms
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--dkms.conf2
3 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c09a723d4d76..d9645f19c53c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = can-isotp-dkms-git
pkgdesc = Kernel modules for isotp
pkgver = r14.6003f99
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hartkopp/can-isotp
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = can-isotp-dkms-git
source = git+https://github.com/hartkopp/can-isotp.git
source = dkms.conf
sha256sums = SKIP
- sha256sums = 8224438ae2136eb5e423daf475168b337707539440c9024b97a9493c6c3e793e
+ sha256sums = 4e69b728bacd8aba3281b55aef2da2e8737d6a380be2d8ed397e09f79651f317
pkgname = can-isotp-dkms-git
diff --git a/PKGBUILD b/PKGBUILD
index aab50db421d6..3af79844bee5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=can-isotp-dkms-git
_pkgbase=can-isotp
pkgver=r14.6003f99
-pkgrel=1
+pkgrel=2
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
pkgdesc="Kernel modules for isotp"
@@ -18,7 +18,7 @@ optdepends=('can-utils: utilities for sending and receiving ISOTP messges'
source=("git+https://github.com/hartkopp/can-isotp.git"
'dkms.conf')
sha256sums=('SKIP'
- '8224438ae2136eb5e423daf475168b337707539440c9024b97a9493c6c3e793e')
+ '4e69b728bacd8aba3281b55aef2da2e8737d6a380be2d8ed397e09f79651f317')
pkgver() {
cd "$srcdir/${_pkgbase}"
@@ -35,6 +35,11 @@ package() {
# Copy dkms.conf
install -Dm644 dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+ # Patch makefile to work with dkms, and use the specified kernel release
+ sed -e s/else// \
+ -e s/shell\ uname\ \-r/KERNELRELEASE/ \
+ -i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/Makefile
+
# Set name and version
sed -e "s/@_PKGBASE@/${_pkgbase}/" \
-e "s/@PKGVER@/${pkgver}/" \
diff --git a/dkms.conf b/dkms.conf
index 923545719998..557b88302afa 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -1,6 +1,6 @@
PACKAGE_NAME="@_PKGBASE@"
PACKAGE_VERSION="@PKGVER@"
-MAKE[0]="'make' modules"
+MAKE[0]="make modules"
CLEAN="make clean"
BUILT_MODULE_NAME[0]="@_PKGBASE@"
DEST_MODULE_LOCATION[0]="/kernel/drivers/net/can"