summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-02-15 23:34:42 +0000
committerGonçalo Camelo Neves Pereira2018-02-15 23:34:42 +0000
commit7c52f17450e46992f7938366282f869d3d2acb05 (patch)
treed8d0a9b5d4c30f1009ab8fc449fbe17ac46b9cbf
parentca22cb29a85bc3ab059a703fd5eeb57461b2a680 (diff)
downloadaur-7c52f17450e46992f7938366282f869d3d2acb05.tar.gz
clean file
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5c243cacc1e..ef5bff8f90f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,14 +3,11 @@ pkgbase = can-utils
pkgver = 2018.02.0
pkgrel = 2
url = https://github.com/linux-can/can-utils
- arch = any
+ arch = x86_64
license = GPLv2
- makedepends = libtool
- provides = can-utils
conflicts = can-utils-git
- replaces = can-utils-git
- source = https://github.com/linux-can/can-utils/archive/v2018.02.0.tar.gz
- sha256sums = SKIP
+ source = can-utils-2018.02.0.tar.gz::https://github.com/linux-can/can-utils/archive/v2018.02.0.tar.gz
+ sha256sums = 370ad4b19447c29099f7300548f1a3362d6e123c4a6a827dbbd3110bc2c26839
pkgname = can-utils
diff --git a/PKGBUILD b/PKGBUILD
index d49a205d118e..71abe61e0c44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,27 +5,21 @@ pkgver=2018.02.0
_pkgname=can-utils-${pkgver}
pkgrel=2
pkgdesc="Linux-CAN / SocketCAN user space applications"
-arch=('any')
+arch=('x86_64')
url="https://github.com/linux-can/can-utils"
license=('GPLv2')
-makedepends=("libtool")
-provides=("can-utils")
-replaces=("can-utils-git")
conflicts=("can-utils-git")
-source=("https://github.com/linux-can/can-utils/archive/v2018.02.0.tar.gz")
-sha256sums=('SKIP')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('370ad4b19447c29099f7300548f1a3362d6e123c4a6a827dbbd3110bc2c26839')
build() {
- cd "${srcdir}"
- tar -xzf v2018.02.0.tar.gz
- pwd
- cd "${_pkgname}"
+ cd ${pkgname}-${pkgver}
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/${_pkgname}"
- make DESTDIR="$pkgdir/" install
+ cd ${pkgname}-${pkgver}
+ make install
}