summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarenome Ranaivoarivony-Razanajato2017-03-20 12:02:05 +0100
committerHarenome Ranaivoarivony-Razanajato2017-03-20 12:02:41 +0100
commit4239b3ccfdaaf4244ece0ba957f46c5e40aecd22 (patch)
tree2d9ea46fa6f2826622a6d8f27fc09ae6a49d8320
downloadaur-4239b3ccfdaaf4244ece0ba957f46c5e40aecd22.tar.gz
candl 0.6.2+
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD58
-rw-r--r--configure.ac.patch8
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f5171584734
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = candl-git
+ pkgdesc = Data Dependence Analysis Tool in the Polyhedral Model
+ pkgver = 0.6.2.r73.ad0fa5a
+ pkgrel = 1
+ url = http://icps.u-strasbg.fr/people/bastoul/public_html/development/candl/
+ arch = x86_64
+ license = LGPL3
+ depends = gmp
+ depends = isl
+ depends = osl
+ depends = piplib-git
+ provides = candl
+ source = candl-git::git+https://github.com/periscop/candl.git
+ source = configure.ac.patch
+ md5sums = SKIP
+ md5sums = 02f099e2c18447128f863b16e013a122
+
+pkgname = candl-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2f8ab8cdc1ef
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+# As advised in the arch wiki page for AUR, ignore everything.
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..871a7948d7d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Harenome Ranaivoarivony-Razanajato
+# <ranaivoarivony-razanajato@hareno.me>
+
+pkgname=candl-git
+pkgver=0.6.2.r73.ad0fa5a
+pkgrel=1
+pkgdesc="Data Dependence Analysis Tool in the Polyhedral Model"
+arch=(x86_64)
+url="http://icps.u-strasbg.fr/people/bastoul/public_html/development/candl/"
+license=('LGPL3')
+depends=("gmp" "isl" "osl" "piplib-git")
+provides=("candl")
+source=(
+ ${pkgname}::git+https://github.com/periscop/candl.git
+ configure.ac.patch
+)
+md5sums=(
+ 'SKIP'
+ '02f099e2c18447128f863b16e013a122'
+)
+
+pkgver() {
+ # `git describe` can not be used because there are no tags in the GitHub
+ # repository. Commit 5db92063d176980bbb1c51b6974440069d440409 was tagged
+ # '0.6.2' in the old git repository (http://repo.or.cz/candl.git/).
+ cd "${srcdir}/${pkgname}"
+ printf "0.6.2.r%s.%s" \
+ "$(git rev-list --count 5db92063d176980bbb1c51b6974440069d440409..HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch -i "${srcdir}/configure.ac.patch" "configure.ac"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ autoreconf -i
+ ./configure \
+ --prefix=/usr \
+ --with-gmp=system \
+ --with-osl=system \
+ --with-piplib=system \
+ --enable-mp-version
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}"
+ # Run sequentially the tests because there is a race condition on the tests.
+ make -j 1 check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/configure.ac.patch b/configure.ac.patch
new file mode 100644
index 000000000000..0e726d38d874
--- /dev/null
+++ b/configure.ac.patch
@@ -0,0 +1,8 @@
+125c125
+< OSL_LIBS="$with_osl_prefix/lib/libosl.la -losl"
+---
+> OSL_LIBS="-losl"
+237c237
+< PIPLIB_LIBS="$with_piplib_prefix/lib/lib$PIPLIB_LA.la -l$PIPLIB_LA"
+---
+> PIPLIB_LIBS="-l$PIPLIB_LA"