summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTarn W. Burton2023-12-31 09:29:07 -0500
committerTarn W. Burton2023-12-31 09:29:07 -0500
commit1ea437b26013e5d05a2fb7af6a9d30edc5119d34 (patch)
tree6b30006bdd21becbac65452b405640f21415e64f
parent6831f93320253d561fc8e508950b5e68cf8560c9 (diff)
downloadaur-1ea437b26013e5d05a2fb7af6a9d30edc5119d34.tar.gz
Update version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--pkgver.lisp5
3 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df56ec1464ce..7c73ac078b98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cando-git
pkgdesc = Bringing Common Lisp and C++ Together, including Cando
- pkgver = 2.4.0_1_g86851e585_g3d4a3fcd
+ pkgver = 2.4.0.r244.g0c719f1d9.gfc99a3fa
pkgrel = 1
url = https://github.com/clasp-developers/clasp
arch = x86_64
@@ -32,6 +32,8 @@ pkgbase = cando-git
conflicts = clasp-cl-git
options = !strip
source = git+https://github.com/clasp-developers/clasp.git
+ source = pkgver.lisp
sha512sums = SKIP
+ sha512sums = 4c6092823f538bca39176944e913904c6a86a12934d27a641eeaec0cd8f1b8cdd3d8acfc86ef0a6f676869930edf29b0f900ac48e647385fece9544150bb2db5
pkgname = cando-git
diff --git a/PKGBUILD b/PKGBUILD
index a4681d8065dc..b341f44272e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tarn W. Burton <twburton@gmail.com>
pkgname=cando-git
-pkgver=2.4.0_1_g86851e585_g3d4a3fcd
+pkgver=2.4.0.r244.g0c719f1d9.gfc99a3fa
pkgrel=1
pkgdesc="Bringing Common Lisp and C++ Together, including Cando"
arch=('x86_64')
@@ -12,18 +12,20 @@ depends=('boost' 'expat' 'fmt' 'gmp' 'libbsd' 'libedit' 'clang' 'zeromq'
makedepends=('git' 'sbcl' 'pkg-config')
provides=('cclasp-boehm' 'common-lisp' 'clasp-cl' 'cando')
conflicts=('cando' 'clasp-cl' 'clasp-cl-git')
-source=('git+https://github.com/clasp-developers/clasp.git')
-sha512sums=('SKIP')
+source=('git+https://github.com/clasp-developers/clasp.git'
+ 'pkgver.lisp')
+sha512sums=('SKIP'
+ '4c6092823f538bca39176944e913904c6a86a12934d27a641eeaec0cd8f1b8cdd3d8acfc86ef0a6f676869930edf29b0f900ac48e647385fece9544150bb2db5')
prepare() {
cd clasp
- ./koga --reproducible-build --package-path=$pkgdir --extensions=cando,seqan-clasp --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/
+ ./koga --reproducible-build --package-path=$pkgdir --extensions=cando,seqan-clasp --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/ --skip-sync=ansi-test,mps,cl-bench,cl-who
./koga --skip-sync --extensions=cando,seqan-clasp --update-version
}
pkgver() {
cd clasp
- sbcl --noinform --non-interactive --eval "(write-string (substitute #\_ #\- (getf (with-open-file (s \"version.sexp\") (read s)) :version)))"
+ sbcl --noinform --non-interactive --load ../../pkgver.lisp
}
build() {
diff --git a/pkgver.lisp b/pkgver.lisp
new file mode 100644
index 000000000000..55c724488251
--- /dev/null
+++ b/pkgver.lisp
@@ -0,0 +1,5 @@
+(let* ((version (getf (with-open-file (s "version.sexp") (read s)) :version))
+ (p (position #\- version)))
+ (write-string (subseq version 0 p))
+ (write-string ".r")
+ (write-string (substitute #\. #\- (subseq version (1+ p)))))