summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTarn W. Burton2022-06-07 10:30:42 -0400
committerTarn W. Burton2022-06-07 10:30:42 -0400
commit58bd640b79a40c063fa353f56a7f0faaef7f4861 (patch)
treecf52294426aee6b31e5c9081fd4a99ce6f419303
parente4541569bf0ceb7ba6c4fb05219ae789ecb2af82 (diff)
downloadaur-58bd640b79a40c063fa353f56a7f0faaef7f4861.tar.gz
Update versioning scheme
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9733be4a022e..7a282423eba7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cando-git
pkgdesc = Bringing Common Lisp and C++ Together, including Cando
- pkgver = 1.0.0.r214.gfdfb2e6d3
+ pkgver = 1.0.0_262_g0eb80f93e_gbcbf18c5
pkgrel = 1
url = https://github.com/clasp-developers/clasp
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index de509feb78ea..b749ff6f76f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tarn W. Burton <twburton@gmail.com>
pkgname=cando-git
-pkgver=1.0.0.r214.gfdfb2e6d3
+pkgver=1.0.0_262_g0eb80f93e_gbcbf18c5
pkgrel=1
pkgdesc="Bringing Common Lisp and C++ Together, including Cando"
arch=('x86_64')
@@ -15,14 +15,19 @@ conflicts=('clasp-cl-git')
source=('git+https://github.com/clasp-developers/clasp.git')
sha512sums=('SKIP')
+prepare() {
+ cd clasp
+ ./koga --package-path=$pkgdir --extensions=cando,seqan-clasp --jupyter --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/ --jupyter-path=/usr/share/jupyter/
+ ./koga --skip-sync --extensions=cando,seqan-clasp --update-version
+}
+
pkgver() {
cd clasp
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ sbcl --noinform --non-interactive --eval "(write-string (substitute #\_ #\- (getf (with-open-file (s \"version.sexp\") (read s)) :version)))"
}
build() {
cd clasp
- ./koga --package-path=$pkgdir --extensions=cando,seqan-clasp --jupyter --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/ --jupyter-path=/usr/share/jupyter/
ninja -C build
}
@@ -30,4 +35,3 @@ package() {
cd clasp
ninja -C build install
}
-