summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTarn W. Burton2022-05-23 12:50:02 -0400
committerTarn W. Burton2022-05-23 12:50:02 -0400
commite4541569bf0ceb7ba6c4fb05219ae789ecb2af82 (patch)
tree8154dc35766140d539fcc782e5163034dcb39773
downloadaur-e4541569bf0ceb7ba6c4fb05219ae789ecb2af82.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD33
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9733be4a022e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = cando-git
+ pkgdesc = Bringing Common Lisp and C++ Together, including Cando
+ pkgver = 1.0.0.r214.gfdfb2e6d3
+ pkgrel = 1
+ url = https://github.com/clasp-developers/clasp
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = sbcl
+ makedepends = ninja
+ makedepends = pkg-config
+ depends = boost
+ depends = expat
+ depends = fmt
+ depends = gmp
+ depends = libbsd
+ depends = libedit
+ depends = clang
+ depends = zeromq
+ depends = libelf
+ depends = libffi
+ depends = llvm
+ depends = netcdf
+ depends = ncurses
+ depends = zlib
+ provides = cclasp-boehm
+ provides = common-lisp
+ provides = clasp-cl
+ provides = cando
+ conflicts = clasp-cl-git
+ options = !strip
+ source = git+https://github.com/clasp-developers/clasp.git
+ sha512sums = SKIP
+
+pkgname = cando-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cf1b01442a6d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.tar.gz
+*.zst
+clasp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de509feb78ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tarn W. Burton <twburton@gmail.com>
+pkgname=cando-git
+pkgver=1.0.0.r214.gfdfb2e6d3
+pkgrel=1
+pkgdesc="Bringing Common Lisp and C++ Together, including Cando"
+arch=('x86_64')
+url="https://github.com/clasp-developers/clasp"
+license=('LGPL')
+options+=(!strip)
+depends=('boost' 'expat' 'fmt' 'gmp' 'libbsd' 'libedit' 'clang' 'zeromq'
+ 'libelf' 'libffi' 'llvm' 'netcdf' 'ncurses' 'zlib')
+makedepends=('git' 'sbcl' 'ninja' 'pkg-config')
+provides=('cclasp-boehm' 'common-lisp' 'clasp-cl' 'cando')
+conflicts=('clasp-cl-git')
+source=('git+https://github.com/clasp-developers/clasp.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd clasp
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd clasp
+ ./koga --package-path=$pkgdir --extensions=cando,seqan-clasp --jupyter --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/ --jupyter-path=/usr/share/jupyter/
+ ninja -C build
+}
+
+package() {
+ cd clasp
+ ninja -C build install
+}
+