summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-08-24 06:53:44 +0200
committerCarsten Teibes2014-08-24 06:53:44 +0200
commitb1c1fd29d980327a9d57ebab35566fb60f9efdca (patch)
tree7946874ae66c51ef8407e63fc483b93896fb5432
parent1fccecd1c2d10bfa66b90ded90ef4b006966d224 (diff)
downloadaur-b1c1fd29d980327a9d57ebab35566fb60f9efdca.tar.gz
Cleanup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD39
2 files changed, 24 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fb6bc7921d5..71f569215224 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,14 +10,16 @@ pkgbase = cannonball-git
makedepends = git
makedepends = cmake
makedepends = boost
+ makedepends = chrpath
depends = sdl
+ depends = gcc-libs
depends = bash
provides = cannonball
conflicts = cannonball
source = cannonball::git+https://github.com/djyt/cannonball.git
source = cannonball.sh
- md5sums = SKIP
- md5sums = 06ea516bc9a4454da988074465e25943
+ sha256sums = SKIP
+ sha256sums = 3400daeb32033967e2e6a8202ab38943786f8b9d61b662e77d4caaeb47d89277
pkgname = cannonball-git
diff --git a/PKGBUILD b/PKGBUILD
index e77897791e29..e79cee56e478 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,50 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-_pkgbase=cannonball
-pkgname=$_pkgbase-git
+pkgname=cannonball-git
pkgver=0.22.r3.g9b5ed35
pkgrel=1
pkgdesc='Enhanced OutRun Engine (development version)'
arch=('i686' 'x86_64')
url="http://reassembler.blogspot.de/"
license=('custom')
-depends=('sdl' 'bash')
-makedepends=('git' 'cmake' 'boost')
-conflicts=("$_pkgbase")
-provides=("$_pkgbase")
-install=$_pkgbase.install
-source=($_pkgbase::"git+https://github.com/djyt/cannonball.git"
- "$_pkgbase.sh")
-md5sums=('SKIP'
- '06ea516bc9a4454da988074465e25943')
+depends=('sdl' 'gcc-libs' 'bash')
+makedepends=('git' 'cmake' 'boost' 'chrpath')
+conflicts=("${pkgname%-*}")
+provides=("${pkgname%-*}")
+install=${pkgname%-*}.install
+source=(${pkgname%-*}::"git+https://github.com/djyt/cannonball.git"
+ "${pkgname%-*}.sh")
+sha256sums=('SKIP'
+ '3400daeb32033967e2e6a8202ab38943786f8b9d61b662e77d4caaeb47d89277')
pkgver() {
- cd $_pkgbase
+ cd ${pkgname%-*}
git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
prepare() {
- cd $_pkgbase
+ cd ${pkgname%-*}
rm -rf build
mkdir build
}
build() {
- cd $_pkgbase/build
+ cd ${pkgname%-*}/build
cmake ../cmake -DTARGET=debian
make
}
package() {
- cd $_pkgbase
+ cd ${pkgname%-*}
# launcher + binary
- install -Dm755 ../$_pkgbase.sh "$pkgdir"/usr/bin/$_pkgbase
- install -Dm755 build/$_pkgbase "$pkgdir"/usr/lib/$_pkgbase/$_pkgbase
+ install -Dm755 ../${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
+ install -Dm755 build/${pkgname%-*} "$pkgdir"/usr/lib/${pkgname%-*}/${pkgname%-*}
+ # remove rpath
+ chrpath -d "$pkgdir"/usr/lib/${pkgname%-*}/${pkgname%-*}
# config
- install -Dm644 build/config.xml "$pkgdir"/usr/share/$_pkgbase/config.xml
+ install -Dm644 build/config.xml "$pkgdir"/usr/share/${pkgname%-*}/config.xml
# doc + license
install -Dm644 roms/roms.txt "$pkgdir"/usr/share/doc/$pkgname/roms.txt
install -Dm644 docs/license.txt "$pkgdir"/usr/share/licenses/$pkgname/license.txt