summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCobbCoding2024-01-13 20:20:28 -0500
committerCobbCoding2024-01-13 20:20:28 -0500
commit4be23537191201f7d7516a459868cad6799cc031 (patch)
treec604bd6c239e0bced308b926a19a67f2415168c2
parentd31216b4d918ead016d8f05df2f2cb8c759f9b7b (diff)
downloadaur-4be23537191201f7d7516a459868cad6799cc031.tar.gz
setting up repo
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 354cddb1eed8..417394792910 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
-pkgbase = cano
+pkgbase = cano-git
pkgdesc = Terminal-based modal text editor
- pkgver = r92.cde2854
+ pkgver = r93.8efde9f
pkgrel = 1
url = https://github.com/CobbCoding1/cano
arch = x86_64
license = APACHE
makedepends = git
makedepends = make
- makedepends = ncurses
makedepends = gcc
depends = ncurses
depends = glibc
source = cano::git+https://github.com/CobbCoding1/cano.git
md5sums = SKIP
-pkgname = cano
+pkgname = cano-git
diff --git a/PKGBUILD b/PKGBUILD
index 163776545b0d..7b4044dc8044 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: CobbCoding
-pkgname='cano'
-pkgver=r92.cde2854
+pkgname=cano-git
+_pkgname=cano
+pkgver=r93.8efde9f
pkgrel=1
pkgdesc="Terminal-based modal text editor"
arch=('x86_64')
url="https://github.com/CobbCoding1/cano"
license=('APACHE')
depends=('ncurses' 'glibc')
-makedepends=('git' 'make' 'ncurses' 'gcc')
-source=("$pkgname::git+https://github.com/CobbCoding1/$pkgname.git")
+makedepends=('git' 'make' 'gcc')
+source=("$_pkgname::git+https://github.com/CobbCoding1/$_pkgname.git")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$pkgname"
+ cd "$_pkgname"
make -B
}
package() {
- cd "$pkgname"
- install -Dm755 ./build/"$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm755 ./README.md "$pkgdir/usr/share/doc/$pkgname"
+ cd "$_pkgname"
+ install -Dm755 ./build/"$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 ./README.md "$pkgdir/usr/share/doc/$_pkgname"
}