summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCobbCoding2024-01-13 20:01:03 -0500
committerCobbCoding2024-01-13 20:01:03 -0500
commitd31216b4d918ead016d8f05df2f2cb8c759f9b7b (patch)
treef7c70778bd8389305a418375ed05fea9282c71ec
downloadaur-d31216b4d918ead016d8f05df2f2cb8c759f9b7b.tar.gz
creating initial aur package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..354cddb1eed8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cano
+ pkgdesc = Terminal-based modal text editor
+ pkgver = r92.cde2854
+ pkgrel = 1
+ url = https://github.com/CobbCoding1/cano
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ makedepends = make
+ makedepends = ncurses
+ makedepends = gcc
+ depends = ncurses
+ depends = glibc
+ source = cano::git+https://github.com/CobbCoding1/cano.git
+ md5sums = SKIP
+
+pkgname = cano
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..163776545b0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: CobbCoding
+pkgname='cano'
+pkgver=r92.cde2854
+pkgrel=1
+pkgdesc="Terminal-based modal text editor"
+arch=('x86_64')
+url="https://github.com/CobbCoding1/cano"
+license=('APACHE')
+depends=('ncurses' 'glibc')
+makedepends=('git' 'make' 'ncurses' 'gcc')
+source=("$pkgname::git+https://github.com/CobbCoding1/$pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ make -B
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 ./build/"$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 ./README.md "$pkgdir/usr/share/doc/$pkgname"
+}