summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Carr2020-03-24 19:51:51 -0400
committerMatthew Carr2020-03-24 19:51:51 -0400
commitd3aa92caab781605810241f2f5f1d885f1376aa8 (patch)
tree30cf30b4f47ff0f8b18d769ed6dfe7002b563ffb
downloadaur-d3aa92caab781605810241f2f5f1d885f1376aa8.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD84
-rw-r--r--canon-maxify-mb5100-complete-scangear-icon.pngbin0 -> 5788 bytes
-rw-r--r--canon-maxify-mb5100-complete-scangear.desktop7
-rw-r--r--canon-maxify-mb5100-complete.install24
5 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..112630c4264e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = canon-maxify-mb5100-complete
+pkgdesc = Complete stand alone driver set (printing and scanning) for Canon maxify MB5100 series.
+pkgver = 5.40
+pkgrel = 1
+url = https://www.usa.canon.com/internet/portal/us/home/support/details/printers/small-office-home-office-printers/mb5120
+install = canon-maxify-mb5100-complete.install
+arch = i686
+arch = x86_64
+license = custom
+makedepends = deb2targz
+makedepends = sed
+depends = popt
+depends = libpng12
+depends = libusb-compat
+depends = libtiff
+depends = libxml2
+depends = gtk2
+source = http://gdlp01.c-wss.com/gds/9/0100008399/01/cnijfilter2-5.40-1-deb.tar.gz
+source = http://gdlp01.c-wss.com/gds/2/0100008402/01/scangearmp2-3.40-1-deb.tar.gz
+source = canon-maxify-mb5100-complete-scangear.desktop
+source = canon-maxify-mb5100-complete-scangear-icon.png
+sha256sums = 3b298716ad8b806fad72ed52714838921dea6f84253446a02d0e669afbc13804
+sha256sums = bb8d108b2c3557f3dc258d47b560ce96608a006ec7b052a630e0a5f911da2413
+sha256sums = 3acb5003d7d2b71bf2ecf9d9cd57872f20b182ab0df5e9d5528649f5fbd391c0
+sha256sums = 29dbc682d3f22d79f580bda54801d1f4ef261d857c756eaf4db29e1313406bcc
+
+pkgname = canon-maxify-mb5100-complete
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6de5f0470a0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# Maintainer: Matthew Carr <mdcarr941 at gmail>
+
+# Based on PKGBUILD from https://aur.archlinux.org/packages/canon-pixma-ts5055-complete/
+# which is maintained by Malte Ohmstede.
+# Scanner icon source: http://openiconlibrary.sourceforge.net/gallery2/open_icon_library-full/icons/png/64x64/devices/scanner-3.png
+# The icon source URL isn't alive anymore
+
+pkgname=canon-maxify-mb5100-complete
+pkgver=5.40
+pkgrel=1
+pkgdesc="Complete stand alone driver set (printing and scanning) for Canon maxify MB5100 series."
+url='https://www.usa.canon.com/internet/portal/us/home/support/details/printers/small-office-home-office-printers/mb5120'
+arch=('i686' 'x86_64')
+license=('custom')
+install="${pkgname}.install"
+if [[ ${CARCH} == 'x86_64' ]]; then
+ depends=('popt' 'libpng12' 'libusb-compat' 'libtiff' 'libxml2' 'gtk2')
+ _printDrvDebCommon='cnijfilter2_5.40-1_amd64'
+ _scanDrvDebCommon='scangearmp2_3.40-1_amd64'
+elif [[ ${CARCH} == 'i686' ]]; then
+ depends=('popt' 'lib32-libpng12' 'libusb-compat' 'lib32-libtiff' 'lib32-libxml2' 'gtk2')
+ _printDrvDebCommon='cnijfilter2_5.40-1_i386'
+ _scanDrvDebCommon='scangearmp2_3.40-1_i386'
+fi
+makedepends=('deb2targz' 'sed')
+source=('http://gdlp01.c-wss.com/gds/9/0100008399/01/cnijfilter2-5.40-1-deb.tar.gz'
+ 'http://gdlp01.c-wss.com/gds/2/0100008402/01/scangearmp2-3.40-1-deb.tar.gz'
+ "${pkgname}-scangear.desktop"
+ "${pkgname}-scangear-icon.png")
+
+sha256sums=('3b298716ad8b806fad72ed52714838921dea6f84253446a02d0e669afbc13804'
+ 'bb8d108b2c3557f3dc258d47b560ce96608a006ec7b052a630e0a5f911da2413'
+ '3acb5003d7d2b71bf2ecf9d9cd57872f20b182ab0df5e9d5528649f5fbd391c0'
+ '29dbc682d3f22d79f580bda54801d1f4ef261d857c756eaf4db29e1313406bcc')
+
+_printDrvSrc='cnijfilter2-5.40-1-deb'
+_scanDrvSrc='scangearmp2-3.40-1-deb'
+
+_ppdFile="canonmb5100.ppd"
+
+build(){
+ cd ${srcdir}
+
+ # Unpack driver source files
+
+ tar xvzf ${_printDrvSrc}.tar.gz
+ tar xvzf ${_scanDrvSrc}.tar.gz
+
+ rm -v *.tar.gz
+}
+
+package(){
+ cd ${pkgdir}
+
+ # Unpack debian installer files
+
+ cp "${srcdir}/${_printDrvSrc}/packages/${_printDrvDebCommon}.deb" .
+ cp "${srcdir}/${_scanDrvSrc}/packages/${_scanDrvDebCommon}.deb" .
+
+ deb2targz "${_printDrvDebCommon}.deb"
+ deb2targz "${_scanDrvDebCommon}.deb"
+
+ rm -v *.deb
+
+ tar xzvf "${_printDrvDebCommon}.tar.gz"
+ tar xzvf "${_scanDrvDebCommon}.tar.gz"
+
+ rm -v *.tar.gz
+
+ # Move ppd file to where cups expects
+
+ install -vDm 644 "${pkgdir}/usr/share/ppd/${_ppdFile}" "${pkgdir}/usr/share/cups/model/${_ppdFile}"
+
+ rm -vrf ${pkgdir}/usr/share/ppd
+
+ # Install license files
+
+ find ${pkgdir}/usr/share/doc/ -name 'LICENSE*' -execdir install -vDm 644 {} "${pkgdir}/usr/share/licenses/${pkgname}/{}" \;
+
+ # Install entry in application menu, including icon
+
+ install -vDm 644 "${srcdir}/${pkgname}-scangear.desktop" "${pkgdir}/usr/share/applications/${pkgname}-scangear.desktop"
+ install -vDm 644 "${srcdir}/${pkgname}-scangear-icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}-scangear-icon.png"
+}
diff --git a/canon-maxify-mb5100-complete-scangear-icon.png b/canon-maxify-mb5100-complete-scangear-icon.png
new file mode 100644
index 000000000000..8a886cc53f7c
--- /dev/null
+++ b/canon-maxify-mb5100-complete-scangear-icon.png
Binary files differ
diff --git a/canon-maxify-mb5100-complete-scangear.desktop b/canon-maxify-mb5100-complete-scangear.desktop
new file mode 100644
index 000000000000..f6f11c5b1eb5
--- /dev/null
+++ b/canon-maxify-mb5100-complete-scangear.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Canon Scangear
+Exec=/usr/bin/scangearmp2
+Icon=/usr/share/pixmaps/canon-maxify-mb5100-complete-scangear-icon.png
+Categories=Graphics;2DGraphics;
+Name[en_US]=canon-maxify-mb5100-complete-scangear.desktop
diff --git a/canon-maxify-mb5100-complete.install b/canon-maxify-mb5100-complete.install
new file mode 100644
index 000000000000..5243ffcb3a98
--- /dev/null
+++ b/canon-maxify-mb5100-complete.install
@@ -0,0 +1,24 @@
+post_install() {
+ echo
+ echo -e "\e[1m\e[97m\e[44m====================================================================================>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[1mFinal steps you have to take:\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m Connect & turn on your printer"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m Run command"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[47m\e[30mcnijlgmon3\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m This should give you the address of your printer."
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m Now you can register it with"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[47m\e[30msudo lpadmin -p MB5100 -m canonmb5100.ppd -v <printer-address> -E\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[1mHow to scan:\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m A 'Cannon Scangear' icon has been installed in your application menu."
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m Alternatively, run this command from the command line:"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[47m\e[30mscangearmp2\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m====================================================================================>\e[0m "
+ echo
+}