summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxificurC2018-01-16 21:16:43 +0100
committerxificurC2018-01-16 21:16:43 +0100
commitc656db28b45c91786e8cad8cb96b53c6c4796b5e (patch)
tree26c871df16bb457eb26bb1428aa3d918559e1c27
downloadaur-canon-pixma-mg3000-complete.tar.gz
adds initial mg3000 files
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD83
-rw-r--r--canon-pixma-mg3000-complete-scangear-icon.pngbin0 -> 5788 bytes
-rw-r--r--canon-pixma-mg3000-complete-scangear.desktop7
-rw-r--r--canon-pixma-mg3000-complete.install24
5 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f65ee47a0e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = canon-pixma-mg3000-complete
+ pkgdesc = Complete stand alone driver set (printing and scanning) for Canon Pixma MG3000 series
+ pkgver = 5.40
+ pkgrel = 1
+ url = https://www.canon-europe.com/support/consumer_products/products/fax__multifunctionals/inkjet/pixma_mg_series/pixma_mg3000.aspx
+ install = canon-pixma-mg3000-complete.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = deb2targz
+ makedepends = sed
+ depends = popt
+ depends = libpng12
+ depends = libusb-compat
+ depends = libtiff
+ depends = libxml2
+ depends = gtk2
+ source = http://gdlp01.c-wss.com/gds/9/0100008399/01/cnijfilter2-5.40-1-deb.tar.gz
+ source = http://gdlp01.c-wss.com/gds/2/0100008402/01/scangearmp2-3.40-1-deb.tar.gz
+ source = canon-pixma-mg3000-complete-scangear.desktop
+ source = canon-pixma-mg3000-complete-scangear-icon.png
+ md5sums = 9fde0c1def36fbd38b4d08cd22a2b7a8
+ md5sums = 833f71781ba733fec84f4eb06d468fb4
+ md5sums = 26ebae4fc269fa9d3efa56373345921f
+ md5sums = 3feefd413092d7152f47b7451ba79efe
+
+pkgname = canon-pixma-mg3000-complete
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1aef596e6ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,83 @@
+# Maintainer: Peter Nagy <xificurc at gmail youknow>
+
+# Based on PKGBUILD from https://aur.archlinux.org/packages/canon-pixma-mg5500-complete
+# Scanner icon source: http://openiconlibrary.sourceforge.net/gallery2/open_icon_library-full/icons/png/64x64/devices/scanner-3.png
+# The icon source URL isn't alive anymore
+
+pkgname=canon-pixma-mg3000-complete
+pkgver=5.40
+pkgrel=1
+pkgdesc="Complete stand alone driver set (printing and scanning) for Canon Pixma MG3000 series"
+url='https://www.canon-europe.com/support/consumer_products/products/fax__multifunctionals/inkjet/pixma_mg_series/pixma_mg3000.aspx'
+arch=('i686' 'x86_64')
+license=('custom')
+install="${pkgname}.install"
+if [[ ${CARCH} == 'x86_64' ]]; then
+ depends=('popt' 'libpng12' 'libusb-compat' 'libtiff' 'libxml2' 'gtk2')
+ _printDrvDebCommon='cnijfilter2_5.40-1_amd64'
+ _scanDrvDebCommon='scangearmp2_3.40-1_amd64'
+elif [[ ${CARCH} == 'i686' ]]; then
+ depends=('popt' 'lib32-libpng12' 'libusb-compat' 'lib32-libtiff' 'lib32-libxml2' 'gtk2')
+ _printDrvDebCommon='cnijfilter2_5.40-1_i386'
+ _scanDrvDebCommon='scangearmp2_3.40-1_i386'
+fi
+makedepends=('deb2targz' 'sed')
+source=('http://gdlp01.c-wss.com/gds/9/0100008399/01/cnijfilter2-5.40-1-deb.tar.gz'
+ 'http://gdlp01.c-wss.com/gds/2/0100008402/01/scangearmp2-3.40-1-deb.tar.gz'
+ "${pkgname}-scangear.desktop"
+ "${pkgname}-scangear-icon.png")
+
+md5sums=('9fde0c1def36fbd38b4d08cd22a2b7a8'
+ '833f71781ba733fec84f4eb06d468fb4'
+ '26ebae4fc269fa9d3efa56373345921f'
+ '3feefd413092d7152f47b7451ba79efe')
+
+_printDrvSrc='cnijfilter2-5.40-1-deb'
+_scanDrvSrc='scangearmp2-3.40-1-deb'
+
+_ppdFile="canonmg3000.ppd"
+
+build(){
+ cd ${srcdir}
+
+ # Unpack driver source files
+
+ tar xvzf ${_printDrvSrc}.tar.gz
+ tar xvzf ${_scanDrvSrc}.tar.gz
+
+ rm -v *.tar.gz
+}
+
+package(){
+ cd ${pkgdir}
+
+ # Unpack debian installer files
+
+ cp "${srcdir}/${_printDrvSrc}/packages/${_printDrvDebCommon}.deb" .
+ cp "${srcdir}/${_scanDrvSrc}/packages/${_scanDrvDebCommon}.deb" .
+
+ deb2targz "${_printDrvDebCommon}.deb"
+ deb2targz "${_scanDrvDebCommon}.deb"
+
+ rm -v *.deb
+
+ tar xzvf "${_printDrvDebCommon}.tar.gz"
+ tar xzvf "${_scanDrvDebCommon}.tar.gz"
+
+ rm -v *.tar.gz
+
+ # Move ppd file to where cups expects
+
+ install -vDm 644 "${pkgdir}/usr/share/ppd/${_ppdFile}" "${pkgdir}/usr/share/cups/model/${_ppdFile}"
+
+ rm -vrf ${pkgdir}/usr/share/ppd
+
+ # Install license files
+
+ find ${pkgdir}/usr/share/doc/ -name 'LICENSE*' -execdir install -vDm 644 {} "${pkgdir}/usr/share/licenses/${pkgname}/{}" \;
+
+ # Install entry in application menu, including icon
+
+ install -vDm 644 "${srcdir}/${pkgname}-scangear.desktop" "${pkgdir}/usr/share/applications/${pkgname}-scangear.desktop"
+ install -vDm 644 "${srcdir}/${pkgname}-scangear-icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}-scangear-icon.png"
+}
diff --git a/canon-pixma-mg3000-complete-scangear-icon.png b/canon-pixma-mg3000-complete-scangear-icon.png
new file mode 100644
index 000000000000..8a886cc53f7c
--- /dev/null
+++ b/canon-pixma-mg3000-complete-scangear-icon.png
Binary files differ
diff --git a/canon-pixma-mg3000-complete-scangear.desktop b/canon-pixma-mg3000-complete-scangear.desktop
new file mode 100644
index 000000000000..09abc653bf30
--- /dev/null
+++ b/canon-pixma-mg3000-complete-scangear.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Cannon Scangear (MG5200 series)
+Exec=/usr/bin/scangearmp
+Icon=/usr/share/pixmaps/canon-pixma-mg5200-complete-scangear-icon.png
+Categories=Graphics;2DGraphics;
+Name[en_US]=canon-pixma-mg5500-complete-scangear.desktop
diff --git a/canon-pixma-mg3000-complete.install b/canon-pixma-mg3000-complete.install
new file mode 100644
index 000000000000..ef4a34245f99
--- /dev/null
+++ b/canon-pixma-mg3000-complete.install
@@ -0,0 +1,24 @@
+post_install() {
+ echo
+ echo -e "\e[1m\e[97m\e[44m====================================================================================>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[1mFinal steps you have to take:\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m Connect & turn on your printer"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m Run command"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[47m\e[30mcnijlgmon3\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m This should give you the address of your printer."
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m Now you can register it with"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[47m\e[30msudo lpadmin -p MG3000 -m canonmg3000.ppd -v <printer-address> -E\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[1mHow to scan:\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m A 'Cannon Scangear' icon has been installed in your application menu."
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m Alternatively, run this command from the command line:"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m \e[47m\e[30mscangearmp2\e[0m"
+ echo -e "\e[1m\e[97m\e[44m==>\e[0m "
+ echo -e "\e[1m\e[97m\e[44m====================================================================================>\e[0m "
+ echo
+}