summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorДамјан Георгиевски2021-12-25 13:43:24 +0100
committerДамјан Георгиевски2021-12-25 14:22:25 +0100
commitcddfef68824fab1dd611d50fec24194cbda09a50 (patch)
treeeeabc066872bf2ad3707a5cf99ef784fcf75895b
parent73f26b81120deb82c623403056845352c7dd5fe9 (diff)
downloadaur-cddfef68824fab1dd611d50fec24194cbda09a50.tar.gz
added systemd service file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
-rw-r--r--multipassd.service14
3 files changed, 33 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8040e825eab0..271088a1adff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = canonical-multipass
pkgdesc = Multipass is a lightweight VM manager for Linux, Windows and macOS.
pkgver = 1.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://multipass.run
arch = x86_64
license = GPL3
@@ -18,6 +18,7 @@ pkgbase = canonical-multipass
source = git+https://github.com/Skycoder42/QHotkey.git
source = git+https://github.com/fmtlib/fmt.git
source = git+https://github.com/pocoproject/poco.git
+ source = multipassd.service
source = libssh-static.patch
sha256sums = SKIP
sha256sums = SKIP
@@ -29,6 +30,7 @@ pkgbase = canonical-multipass
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = f7aebd4ab185048ee10e8185ac230c8ac549ff29b2e52722fbf366ad6f3c6b59
sha256sums = 8cc982b96a800c9779134a00e741c472da7c8e11183931ec30b184c314364dde
pkgname = canonical-multipass
diff --git a/PKGBUILD b/PKGBUILD
index a08d4c7833d8..4576fa2868d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=canonical-multipass
_realname=multipass
pkgver=1.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="Multipass is a lightweight VM manager for Linux, Windows and macOS."
arch=('x86_64')
url="https://multipass.run"
@@ -21,10 +21,9 @@ source=("git+https://github.com/canonical/${_realname}.git#tag=v${pkgver}"
git+https://github.com/Skycoder42/QHotkey.git
git+https://github.com/fmtlib/fmt.git
git+https://github.com/pocoproject/poco.git
+ multipassd.service
libssh-static.patch
)
-sha256sums=(SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP
- "8cc982b96a800c9779134a00e741c472da7c8e11183931ec30b184c314364dde")
prepare() {
cd "${srcdir}/${_realname}"
@@ -63,4 +62,18 @@ package() {
make DESTDIR="$pkgdir" install
# not needed in package
rm "$pkgdir"/usr/lib/libssh.a
+ install -Dm644 "$srcdir"/multipassd.service "$pkgdir"/usr/lib/systemd/system/multipassd.service
}
+
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'f7aebd4ab185048ee10e8185ac230c8ac549ff29b2e52722fbf366ad6f3c6b59'
+ '8cc982b96a800c9779134a00e741c472da7c8e11183931ec30b184c314364dde')
diff --git a/multipassd.service b/multipassd.service
new file mode 100644
index 000000000000..04b3de28306c
--- /dev/null
+++ b/multipassd.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Multipass is a mini-cloud on your workstation using native hypervisors
+
+[Service]
+Type=exec
+StateDirectory=multipassd
+Environment=HOME=/var/lib/multipassd
+Environment=DAEMON_CONFIG_HOME=/var/lib/multipassd
+ExecStart=/usr/bin/multipassd
+ProtectHome=true
+ProtectSystem=full
+
+[Install]
+WantedBy=multi-user.target