summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2021-01-07 21:45:30 +0100
committerMorten Linderud2021-01-07 21:45:30 +0100
commitc3655fe0525b3c823d61b6e4e1b05319f9f4350a (patch)
treebf71658552d711a49342f8f3d9ef041cb77fb7eb
downloadaur-c3655fe0525b3c823d61b6e4e1b05319f9f4350a.tar.gz
import from community
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ef98cfa4e6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = canorus
+ pkgdesc = A free music score editor
+ pkgver = 0.7.3rc3
+ pkgrel = 4
+ url = http://www.canorus.org/
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = swig
+ makedepends = qt5-tools
+ makedepends = ruby
+ depends = qt5-svg
+ depends = qt5-webengine
+ depends = alsa-lib
+ depends = zlib
+ depends = python
+ source = https://downloads.sourceforge.net/project/canorus/0.7.3/canorus-0.7.3rc3.tar.bz2
+ sha256sums = c5d470ac6cae696472dcb7176e0cd4545b883ff84ae2dc767a8956546f5b4b15
+
+pkgname = canorus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..845b75ae1001
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Arch Linux Pro Audio <dev@archaudio.org>
+# Contributor: Coenraad van der Westhuizen <chwesthuizen@gmail.com>
+# Contributor: hm_b <holger (at) music-nerds (dot) net>
+
+pkgname=canorus
+pkgver=0.7.3rc3
+pkgrel=4
+pkgdesc="A free music score editor"
+arch=('x86_64')
+url="http://www.canorus.org/"
+license=('GPL')
+depends=('qt5-svg' 'qt5-webengine' 'alsa-lib' 'zlib' 'python')
+makedepends=('cmake' 'swig' 'qt5-tools' 'ruby')
+source=("https://downloads.sourceforge.net/project/canorus/0.7.3/canorus-${pkgver}.tar.bz2")
+sha256sums=('c5d470ac6cae696472dcb7176e0cd4545b883ff84ae2dc767a8956546f5b4b15')
+
+build() {
+ cd $pkgname-$pkgver
+ # stringop-truncation will be fixes in swig, see https://github.com/swig/swig/issues/893
+ export CXXFLAGS+=" -Wno-misleading-indentation -Wno-dangling-else -Wno-stringop-truncation -Wno-deprecated -Wno-deprecated-declarations"
+ cmake . -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="$pkgdir"/usr \
+ -DDEFAULT_DATA_DIR="/usr/share/canorus"
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make install
+ install -d "$pkgdir"/usr/share/{applications,pixmaps}
+ cp canorus.desktop "$pkgdir"/usr/share/applications
+ cp "$pkgdir"/usr/share/{canorus/images/clogosm.png,pixmaps/canorus.png}
+}