summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-09-08 11:11:28 -0600
committerMark Wagie2021-09-08 11:11:28 -0600
commite0c6a059b907c6d63b301ccff311f1706a04bb93 (patch)
tree0d6cfa73d02a38c07e1c89c6cf4b7c724216fd23
parent3cba190b4af9b52f3ef3e47ae3aad732b131d7ce (diff)
downloadaur-canta-gtk-theme.tar.gz
2021-09-08
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD56
3 files changed, 57 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eb170089acb..e8c8e73fea5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = canta-gtk-theme
pkgdesc = Flat Material Design theme for GTK 3, GTK 2 and Gnome-Shell
- pkgver = 2020.01.31
+ pkgver = 2021.09.08
pkgrel = 1
- url = https://github.com/vinceliuice/Canta-theme
+ url = https://www.gnome-look.org/p/1220749
arch = any
license = GPL2
+ makedepends = gnome-shell
makedepends = gtk3
- depends = gtk-engine-murrine
- depends = gtk-engines
- depends = gnome-themes-standard
- depends = sassc
- source = https://github.com/vinceliuice/Canta-theme/archive/2020-01-31.tar.gz
- sha256sums = c08e3d10eb5625024cb778de3f0901bcc73c07959b090e821ca69c0ae15e06b3
+ makedepends = sassc
+ options = !strip
+ source = -2021.09.08.tar.gz::https://github.com/vinceliuice/Canta-theme/archive/refs/tags/2021-09-08.tar.gz
+ sha256sums = 98f6b71fbc46b1b9e1b256588cf930f780952f95c57f48c9922065c8b333bacd
pkgname = canta-gtk-theme
-
+ depends = gnome-themes-extra
+ depends = gtk3
+ optdepends = gtk-engine-murrine: GTK2 theme support
+ optdepends = gtk-engines: GTK2 theme support
+ optdepends = canta-icon-theme: Matching icon theme
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 04f324ac0964..d250a71c4fcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,45 @@
-# Maintainer: Jun Bo Bi <jambonmcyeah@gmail.com>
-
-pkgname=('canta-gtk-theme')
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Jun Bo Bi <jambonmcyeah@gmail.com>
+#pkgname=('canta-gtk-theme' 'canta-icon-theme')
+pkgname=canta-gtk-theme
+#pkgbase=canta-theme
pkgdesc="Flat Material Design theme for GTK 3, GTK 2 and Gnome-Shell"
-pkgver=2020.01.31
-_pkgver=$(echo $pkgver | tr '.' '-')
-_pkgname="Canta-theme-${_pkgver}"
+_pkgver=2021-09-08
+pkgver=${_pkgver//-/.}
pkgrel=1
arch=('any')
-url="https://github.com/vinceliuice/Canta-theme"
+url="https://www.gnome-look.org/p/1220749"
license=('GPL2')
-depends=('gtk-engine-murrine'
- 'gtk-engines'
- 'gnome-themes-standard'
- 'sassc')
-makedepends=('gtk3')
+makedepends=('gnome-shell' 'gtk3' 'sassc')
+options=('!strip')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/vinceliuice/Canta-theme/archive/refs/tags/$_pkgver.tar.gz")
+sha256sums=('98f6b71fbc46b1b9e1b256588cf930f780952f95c57f48c9922065c8b333bacd')
+
+package_canta-gtk-theme() {
+ depends=('gnome-themes-extra' 'gtk3')
+ optdepends=('gtk-engine-murrine: GTK2 theme support'
+ 'gtk-engines: GTK2 theme support'
+ 'canta-icon-theme: Matching icon theme')
+
+ cd "Canta-theme-$_pkgver"
+ install -d "$pkgdir/usr/share/themes"
-source=("${url}/archive/${_pkgver}.tar.gz")
-sha256sums=('c08e3d10eb5625024cb778de3f0901bcc73c07959b090e821ca69c0ae15e06b3')
+ # Install theme with Nautilus background image
+ for theme in standard blue indigo; do
+ ./install.sh -t ${theme} -d "$pkgdir/usr/share/themes"
+ done
-package() {
- cd "${srcdir}/${_pkgname}"
- mkdir -p "${pkgdir}/usr/share/themes"
- ./install.sh -d "${pkgdir}/usr/share/themes"
+ # Install theme without Nautilus background image
+# for theme in standard blue indigo; do
+# ./install.sh -o -t ${theme} -d "$pkgdir/usr/share/themes"
+# done
}
+
+#package_canta-icon-theme() {
+# pkgdesc="Flat icons for Canta GTK theme"
+# optdepends=('numix-circle-icon-theme: if you want a better experience')
+
+# cd "Canta-theme-$_pkgver"
+# install -d "$pkgdir/usr/share/icons"
+# ./install.sh -i -d "$pkgdir/usr/share/icons"
+#}