summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2016-02-04 22:37:22 -0500
committerGötz Christ2016-02-04 22:37:22 -0500
commit49df6a8b7fbeb64dff39a09812b4395df88acef9 (patch)
tree55aa4c04e6328360b8e889b92bab26aec14e7254
parentc412eef9af8c98c7de2f895eec0266712a327f3f (diff)
downloadaur-49df6a8b7fbeb64dff39a09812b4395df88acef9.tar.gz
Update: LibVLC is only used by default for HTTP stream playback, qt5-multimedia works also.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 5 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d636fac5bbc..95c1fb02af96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 24 02:23:08 UTC 2015
+# Fri Feb 5 03:32:57 UTC 2016
pkgbase = cantata-git
pkgdesc = Qt5 graphical client for Music Player Daemon (MPD) - git version.
- pkgver = 1.9.50.r6021.20186cc
+ pkgver = 2.0.50.r6087.55fb716
pkgrel = 1
url = https://github.com/cdrummond/cantata
install = cantata-git.install
diff --git a/PKGBUILD b/PKGBUILD
index ed9ec6496440..02ab071837dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=cantata-git
-pkgver=1.9.50.r6021.20186cc
+pkgver=2.0.50.r6087.55fb716
pkgrel=1
pkgdesc="Qt5 graphical client for Music Player Daemon (MPD) - git version."
arch=('i686' 'x86_64')
@@ -17,20 +17,9 @@ source=("$pkgname::git+https://github.com/CDrummond/cantata.git")
install="${pkgname}.install"
sha1sums=('SKIP')
-# VLC is needed for HTTP Stream Playback. Change to 1 to enable this.
-_USE_VLC=0
-
-if [[ "$_USE_VLC" = '1' ]]
-then
- depends+=('vlc')
- _WITH_VLC='ON'
-else
- _WITH_VLC='OFF'
-fi
-
pkgver() {
cd "${pkgname}"
- printf "1.9.50.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "2.0.50.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
@@ -46,8 +35,7 @@ build() {
cmake ../${pkgname} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DENABLE_HTTP_STREAM_PLAYBACK=$_WITH_VLC \
- -DENABLE_KDE=OFF
+ -DENABLE_LIBVLC=OFF
make
}