summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2015-06-15 13:10:38 -0500
committerGötz Christ2015-06-15 13:10:38 -0500
commitc3b356fa97e7aa3f5d4a7b5e5bee40a71db9df18 (patch)
tree5a8269bc699d74e57b2ad3a86e3d0e6b3f3e8413
downloadaur-c3b356fa97e7aa3f5d4a7b5e5bee40a71db9df18.tar.gz
Initial import
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD47
-rw-r--r--cantata-git.install11
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..350e11a6a526
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = cantata-git
+ pkgdesc = Qt5 client for the Music Player Daemon (MPD) - git version.
+ pkgver = 1.5.2.r5592.9ab375f
+ pkgrel = 1
+ url = https://github.com/cdrummond/cantata
+ install = cantata-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ makedepends = qt5-svg
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = libmtp
+ depends = libcddb
+ depends = libmusicbrainz5
+ depends = mpg123
+ depends = taglib-extras
+ depends = hicolor-icon-theme
+ depends = cdparanoia
+ depends = speex
+ depends = media-player-info
+ depends = udisks2
+ optdepends = perl-uri: dynamic playlist
+ optdepends = mpd: playback
+ optdepends = ffmpeg: ReplayGain support
+ provides = cantata
+ conflicts = cantata
+ conflicts = cantata-kde
+ conflicts = cantata-kde-svn
+ conflicts = cantata-kde-svn
+ source = cantata-git::git+https://github.com/CDrummond/cantata.git
+ sha1sums = SKIP
+
+pkgname = cantata-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6432cf687101
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=cantata-git
+pkgver=1.5.2.r5592.9ab375f
+pkgrel=1
+pkgdesc="Qt5 client for the Music Player Daemon (MPD) - git version."
+arch=('i686' 'x86_64')
+url="https://github.com/cdrummond/cantata"
+license=('GPL3')
+depends=('qt5-multimedia' 'qt5-svg' 'libmtp' 'libcddb' 'libmusicbrainz5' 'mpg123'
+ 'taglib-extras' 'hicolor-icon-theme' 'cdparanoia' 'speex' 'media-player-info' 'udisks2')
+optdepends=('perl-uri: dynamic playlist'
+ 'mpd: playback'
+ 'ffmpeg: ReplayGain support')
+makedepends=('git' 'cmake' 'qt5-tools' 'qt5-svg')
+conflicts=('cantata' 'cantata-kde' 'cantata-kde-svn' 'cantata-kde-svn')
+provides=('cantata')
+source=("$pkgname::git+https://github.com/CDrummond/cantata.git")
+install="${pkgname}.install"
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "1.5.2.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ if [[ -d build ]]
+ then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd build
+ cmake ../${pkgname} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DENABLE_HTTP_STREAM_PLAYBACK=ON \
+ -DENABLE_KDE=OFF -DENABLE_QT5=ON \
+ -DENABLE_UDISKS2=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
+}
diff --git a/cantata-git.install b/cantata-git.install
new file mode 100644
index 000000000000..e70c054ec6ad
--- /dev/null
+++ b/cantata-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}