summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2016-04-13 00:27:46 +0200
committerNarrat2016-04-13 00:27:46 +0200
commitfd341603e5abec03baaa1598b893c373aae85255 (patch)
tree7defe4573f7cb145adfc1552f0f93427baa4d408
parente6d786cb1e541747eed6a485d3f6aec5af9e6495 (diff)
downloadaur-fd341603e5abec03baaa1598b893c373aae85255.tar.gz
Canto-Daemon: and gone is the patch
Fixed py3 bindings from libxml2 package make this patch already obsolete
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--drv_libxml2.patch21
3 files changed, 4 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6235ed5f4352..c2fa3ca7e1d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Apr 10 20:26:01 UTC 2016
+# Tue Apr 12 22:27:47 UTC 2016
pkgbase = canto-daemon
pkgdesc = News aggregator for Atom/RSS/RDF
pkgver = 0.9.5
- pkgrel = 4
+ pkgrel = 5
url = http://codezen.org/canto-ng/
arch = any
license = GPL
@@ -11,9 +11,7 @@ pkgbase = canto-daemon
optdepends = python-requests: Needed by inoreader plugin
provides = canto-next-git=0.9.5
source = https://github.com/themoken/canto-next/archive/v0.9.5.tar.gz
- source = drv_libxml2.patch
md5sums = 128a5e59400bbf6f472c0109e66c6250
- md5sums = 9828e769497a7f8d670343f2fdfab03c
pkgname = canto-daemon
diff --git a/PKGBUILD b/PKGBUILD
index 2acd95e5e681..2c9d26c54f18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=canto-next
pkgname=canto-daemon
pkgver=0.9.5
-pkgrel=4
+pkgrel=5
pkgdesc="News aggregator for Atom/RSS/RDF"
url="http://codezen.org/canto-ng/"
license=('GPL')
@@ -11,18 +11,11 @@ arch=('any')
depends=('python-feedparser')
optdepends=('python-requests: Needed by inoreader plugin')
provides=('canto-next-git=0.9.5')
-source=(https://github.com/themoken/${_pkgname}/archive/v${pkgver}.tar.gz
- drv_libxml2.patch)
+source=(https://github.com/themoken/${_pkgname}/archive/v${pkgver}.tar.gz)
md5sums=('128a5e59400bbf6f472c0109e66c6250'
'9828e769497a7f8d670343f2fdfab03c')
-prepare() {
- cd ${_pkgname}-${pkgver}
- # https://github.com/themoken/canto-next/issues/10
- patch -Np1 -i ${srcdir}/drv_libxml2.patch
-}
-
package() {
cd ${_pkgname}-${pkgver}
diff --git a/drv_libxml2.patch b/drv_libxml2.patch
deleted file mode 100644
index 08c01e551145..000000000000
--- a/drv_libxml2.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-commit 3be0ad8b0a6a89d2a6ed04124f25912039ee2a30
-Author: Martin Zimmermann <info@posativ.org>
-Date: Sun Apr 3 13:42:34 2016 +0200
-
- remove drv_libxml2 from preferred xml parsers, if we get a TypeError, #10
-
-diff --git a/canto_next/remote.py b/canto_next/remote.py
-index bbfe9d6..e5c71fb 100644
---- a/canto_next/remote.py
-+++ b/canto_next/remote.py
-@@ -164,6 +164,10 @@ class CantoRemote(PluginHandler, CantoClient):
- 'Canto/0.9.0 + http://codezen.org/canto-ng' }
- try:
- content = feedparser.parse(URL, request_headers = extra_headers)
-+ except TypeError:
-+ if 'drv_libxml2' in feedparser.PREFERRED_XML_PARSERS:
-+ feedparser.PREFERRED_XML_PARSERS.remove('drv_libxml2')
-+ content = feedparser.parse(URL, request_headers = extra_headers)
- except Exception as e:
- print("ERROR: Couldn't determine name: %s" % e)
- return None